WordPress.org

Making WordPress.org

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#3256 closed defect (invalid)

"Error: Forbidden" showing on ticket creation if user not logged in

Reported by: alkesh7 Owned by:
Milestone: Priority: normal
Component: Trac Keywords: ux-feedback
Cc:

Description

I was trying an URL - https://meta.trac.wordpress.org/newticket to create new ticket on meta channel. And I noticed that page showing me one error on frontend.

That should not be there.

Attachments (1)

Error - Fobidden.png (62.1 KB) - added by alkesh7 18 months ago.

Download all attachments as: .zip

Change History (6)

#1 @jensdevbeule
18 months ago

  • Resolution set to maybelater
  • Status changed from new to closed

Dear alkesh7

Thank you for submitting your defect! This is something we will look back to at a later moment.

#2 @Otto42
18 months ago

  • Resolution changed from maybelater to invalid

Changing the resolution of this ticket, as we have no current plans to change this.

@alkesh7 The message "You are currently not logged in. You may want to do so now." comes from us, the Error: Forbidden comes from Trac. However, this error message is correct, if you're not logged in, then you don't have the proper permissions to submit a new ticket. This is intended behavior.

#3 @alkesh7
18 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

''Error: Forbidden'' not correct with the user point of view.

First tell to user, please login with the site and then if user don't have an any access for same then message is okay.

And still there should not be Error text anywhere on frontend.

Thanks @Otto42 for your first comment.

#4 @Otto42
18 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

It's Trac. It's not a place for users to report issues, as such. It's a place for developers.

The error message is correct. Please do not reopen the ticket.

#5 @Otto42
18 months ago

  • Component changed from Browse Happy to Trac
Note: See TracTickets for help on using tickets.