WordPress.org

Making WordPress.org

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#3410 closed defect (invalid)

Bad user experience in GlotPress, with warnings

Reported by: Travel_girl Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords: has-screenshots needs-testing
Cc:

Description

Hey,

I have struggled in GlotPress when having an error/warning in a translation.

If I accidentally have an error (like ending on new line and so on), I got a warning.

If I change the mistake and want to save it, I can't, because I have to close the warning first:

"You need to close the warning to approve the new string!"

Problem is, I can't close the warning.

So I have to reload and reject my further translation and insert my translation again.
Also when I have selected "untranslated strings only", I can't see this string again, when reloading. I have to select "All" and search for my string to edit it again.

I not even have found out, how to do this process in a simpler way, I just click around, till I can edit it again.

Really annoying.

I get this bad behavior only in Chrome in an older version. It works with no problems in firefox or the actual chrome version.

I have created a screen cast of this:
https://youtu.be/yUeDrdxCZIY

Change History (6)

#1 @Travel_girl
17 months ago

It was a Chrome version from the last few months. So not too old :-)

This ticket was mentioned in Slack in #meta by travelgirl. View the logs.


17 months ago

#3 @ocean90
17 months ago

  • Resolution set to invalid
  • Status changed from new to closed

The warning is not part of GlotPress. Looks like it's coming from GlotDict, see https://github.com/Mte90/GlotDict/blob/2005e9772be7e108539fa7b271fbc24a20b6cc4c/js/glotdict-validation.js#L135.

#4 @Travel_girl
17 months ago

I have testet it and deleted GlotDic and had the same error. So I'm not sure if this is a problem of GlotDic.

#5 @garrett-eclipse
17 months ago

I can confirm that's a GlotDict feature.
You might want to open an issue there instead;
https://github.com/Mte90/GlotDict

I believe this is the one I raised and got closed but would like to se re-raised as I too find it frustrating, relevant tickets;
https://github.com/Mte90/GlotDict/issues/95
https://github.com/Mte90/GlotDict/issues/117

In your GlotDict settings you can disable this and other warnings;
https://i.imgur.com/uW5bxJI.png

#6 @Travel_girl
17 months ago

You are right. So I will reported in github. Thanks for the hint! :-)

Note: See TracTickets for help on using tickets.