WordPress.org

Making WordPress.org

#3654 closed defect (fixed)

Sometimes the update source table version field gets out of sync

Reported by: dd32 Owned by: dd32
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

As reported on slack, there was an issue where a new version of a plugin was released, but it didn't show up in the update checks, despite the new version showing on wordpress.org/plugins.

It turned out that the cause was the update_source table getting out of sync for the plugin. That seems to be a race condition in caches and when the update job is run mid way through a new version of a plugin being released.

I'm going to add a check which validates that the version field is in sync, and not just the dates/disabled status.

See https://wordpress.slack.com/archives/C1LBM36LC/p1527046068000003

Change History (1)

#1 @dd32
16 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 7274:

Plugin Directory: Include the version field in the comparisons for which plugins update_source records are out of date.

Fixes #3654

Note: See TracTickets for help on using tickets.