WordPress.org

Making WordPress.org

#3734 closed enhancement (duplicate)

Enhancement: "Fix all" feature for the Translation Consistency Checker

Reported by: Nao Owned by:
Milestone: Priority: low
Component: Translate Site & Plugins Keywords:
Cc:

Description

This probably has come up in the past but I didn't see any ticket, so I'm writing this up as a wishlist item of a sort.

The Consistency Checker is an invaluable tool for keeping translations across projects, well, consistent.
One thing I wish it had is a feature for GTEs to bulk fix inconsistent exiting translations. When there are dozens of incorrect translations, it's a pain to go through each source to fix them.

It would be nice if we can select one of the translations and replace others with it.

  • Add buttons + text that are only visible to GTEs
  • Is there a better wording for the "Use this" button? "Select" might be ok but it sounds a bit weak for the action.
  • If it's technically easier, the buttons can appear elsewhere (e.g. within the list below)

Attachments (1)

consistency-checker-use-this-buttons.png (101.5 KB) - added by Nao 11 months ago.

Download all attachments as: .zip

Change History (5)

#1 @Nao
11 months ago

  • Type changed from defect to enhancement

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


11 months ago

#4 @ocean90
10 months ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

This is actually a duplicate of #1703.

Note: See TracTickets for help on using tickets.