Making WordPress.org

Opened 4 years ago

Closed 10 days ago

#3944 closed defect (bug) (fixed)

Requests to '/page/0/' and '/page/1/' should 301 redirect to the series root

Reported by: jonoaldersonwp's profile jonoaldersonwp Owned by: dd32's profile dd32
Milestone: Priority: lowest
Component: Support Forums Keywords: seo
Cc:

Change History (8)

#1 @dd32
4 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 8050:

Support Forums: Add a canonical redirect for .../page/[01]/ > .../ as these display the same content. This avoids duplicate content SEO issues.

Fixes #3944.

#2 @jonoaldersonwp
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

These appear to be executing 302 redirects, rather than 301 redirects.

#3 @dd32
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 8096:

Support Forums: Make a canonical redirect a 301

Fixes #3944.

#4 @joostdevalk
3 years ago

  • Keywords seo added

This ticket was mentioned in Slack in #bbpress by netweb. View the logs.


3 years ago

#6 @tobifjellner
10 days ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi friends,
With regards to a report from @webmarket79 in https://core.trac.wordpress.org/ticket/56298, it looks as we need to reopen this ticket, at least for Rosetta sites.

Last edited 10 days ago by tobifjellner (previous) (diff)

This ticket was mentioned in Slack in #meta by tobifjellner. View the logs.


10 days ago

#8 @SergeyBiryukov
10 days ago

  • Resolution set to fixed
  • Status changed from reopened to closed

It looks like this ticket was specifically about the support forums, while #WP56298 highlighted a similar issue that occurs on any WordPress site. That ticket, however, appears to be a duplicate of #WP53362. I think this needs to be fixed in core, so I'm re-closing this for now.

Note: See TracTickets for help on using tickets.