WordPress.org

Making WordPress.org

Opened 6 months ago

Closed 6 months ago

#3984 closed enhancement (duplicate)

Plugin Repository URI

Reported by: whyisjake Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Submitted originally as part of [this comment](https://make.wordpress.org/meta/2018/12/04/wordcamp-us-contributor-day-what-should-we-work-on/#comment-8932).

It would be great if a theme/plugin docblock could contain a ref to the source of the Code, be it Github or some other version control space.

The Plugin URI is an option for this, obviously. Would be nice to follow the NPM model, and have a respository field. Would be nice to surface that field in the sidebar and developer panel.

You can see the repository field next to the homepage [here for Lodash](https://www.npmjs.com/package/lodash).

Attachments (1)

Screen Shot 2018-12-09 at 11.22.42 AM.png (120.1 KB) - added by whyisjake 6 months ago.
Github, with icon.

Download all attachments as: .zip

Change History (2)

@whyisjake
6 months ago

Github, with icon.

#1 @obenland
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3937.

Note: See TracTickets for help on using tickets.