Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4006 closed enhancement (fixed)

Update breakpoint to trigger core notice about outdated PHP version in Servehappy API

Reported by: flixos90's profile flixos90 Owned by: flixos90's profile flixos90
Milestone: Priority: normal
Component: API Keywords: servehappy has-patch


Since WordPress [aims to raise the minimum PHP version requirement]( sooner than later to PHP 5.6, we should update the breakpoint in the Servehappy API to that version, so that the core notice announced for WordPress 5.1 shows up for any site below that version.

Attachments (1)

4006.diff (915 bytes) - added by flixos90 5 years ago.

Download all attachments as: .zip

Change History (5)

5 years ago

#1 @flixos90
5 years ago

  • Keywords has-patch added; needs-patch removed

4006.diff makes the following updates:

  • Recommended PHP version now 7.3 (as released about two weeks ago)
  • Minimum PHP version still actively supported now 7.2 (7.1 now only receives security updates)
  • Minimum PHP version still receiving security updates now 7.1 (7.0 is no longer supported, 5.6 will no longer be supported as of December 31st)
  • Minimum PHP version still acceptable by WordPress now 5.6 (due to intended version bump)

See for the source for these decisions.

This ticket was mentioned in Slack in #core-php by flixos90. View the logs.

5 years ago

#3 @dd32
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 7990:

API: ServeHappy: Bump the required PHP versions to reflect PHP 7.3 as being the latest, and assume that it'll apply for PHP < 5.6, rather than only for PHP 5.2 as previous.

Props flixos90.
Fixes #4006.

#4 @dd32
5 years ago

  • Component changed from General to API
Note: See TracTickets for help on using tickets.