WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#4060 closed enhancement (duplicate)

Create translatable WP Core Readme on wp.org

Reported by: tobifjellner Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Currently, if a translated version of the readme for WordPress core should be included in a localized installation package, the corresponding language team needs to manually create and maintain it and for every new major version of WordPress they need to add a new branch in i18n.svn.wordpress.org

This process is cumbersome:

  • Commit access to i18n.svn is granted separately from the roles Locale Manager/General Translation Editor
  • Any changes to the canonical readme must manually be noticed by the translation team and updated in the translation
  • And then only whoever has commit access to i18n.svn is able to commit this change.

I suggest a different approach:

  • Create the readme as a generated page on wordpress.org say at xx.wordpress.org/core-readme
  • Make all relevant strings translatable via translate.wordpress.org
  • In the build process for localized installation packages, the current state of the corresponding localized readme is fetched and added with a separate filename (for instance using the locale code: readme-sv-SE.html)

The wording in the readme will need to mention that the readme is generic and primarily reflects the latest major version of WordPress, and that the information in the file readme.html (in English) would be more valid if there's a difference between the two files.

I'm raising this as a meta ticket for now. If we decide to go this path, then when all is ready on wp-org, we'll have to add a step in the build tools for localized wp packages.

Change History (3)

This ticket was mentioned in Slack in #polyglots by tobifjellner. View the logs.


7 months ago

#2 @ocean90
7 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2890.

This ticket was mentioned in Slack in #polyglots by nao. View the logs.


7 months ago

Note: See TracTickets for help on using tickets.