WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#418 closed defect (fixed)

Trac Ticket Author Gravatar disappears when comment preview is created

Reported by: adamsilverstein Owned by: nacin
Milestone: Priority: normal
Component: Trac Keywords: needs-patch
Cc:

Description

When entering a response to a ticket in trac (Chrome Dev/Mac), I noticed that the Gravatar of the original ticket author disappears the first time a preview of my response is generated. I haven't investigated extensively, but here is a screencast of the issue. Note @jeremyfelt's Gravatar disappears when my comment preview is generated.

Change History (11)

#1 @adamsilverstein
5 years ago

I tracked the issue down to this line:
$("#ticket").replaceWith(items.filter('#ticket'));

Here is what i think is happening - when the auto_preview.js fires its ajax callback, it hits the main url to get the page html, the reply from this call is missing the gravatar, so when the replaceWith fires, the gravatar is removed.

I discussed this issue with @nacin at #wcsea and he knows what the problem is and how to fix it.

#2 follow-ups: @nacin
5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

This isn't a simple fix, so I'm just going to wontfix this, just because it's not a big deal.

#3 in reply to: ↑ 2 @adamsilverstein
5 years ago

Replying to nacin:

This isn't a simple fix, so I'm just going to wontfix this, just because it's not a big deal.

Ok, i will block the issue from my mind so I no longer see it :)

#4 in reply to: ↑ 2 ; follow-up: @SergeyBiryukov
5 years ago

Replying to nacin:

This isn't a simple fix, so I'm just going to wontfix this, just because it's not a big deal.

When I'm writing an initial reply to a ticket, I often go to the reporter's WP.org profile. The only link to the profile in that case is under the Gravatar, and when it disappears, it's a big deal for me :)

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#5 @nacin
5 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

OK. Maybe we could just restore it with a little CSS. I'd rather not override the ticket_box.html template, though we could do that pretty sanely, too. I'll look.

#6 in reply to: ↑ 4 @adamsilverstein
5 years ago

  • Cc adam@… added

Replying to SergeyBiryukov:

Replying to nacin:

This isn't a simple fix, so I'm just going to wontfix this, just because it's not a big deal.

When I'm writing an initial reply to a ticket, I often go to the reporter's WP.org profile. The only link to the profile in that case is under the Gravatar, and when it disappears, it's a big deal for me :)

Sergey,

Good point, I'm glad you brought that up.

I have to admit, the disappearing Gravatar wasn't something I was really going to be able to ignore :)

@nacin - if you want a JS solution/kludge that works without modifying anything server side, I can spin that up.

This ticket was mentioned in Slack in #meta by adamsilverstein. View the logs.


4 years ago

#8 @nacin
4 years ago

In 1998:

Add a pristine ticket_preview.html from Trac 1.0.1. see #418.

#9 follow-up: @nacin
4 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from reopened to closed

In 1999:

Trac: Ensure site.html changes are applied to ticket previews.

site.html is not loaded in this case. Thus, split off the functionality into site-ticket.html,
then load site-ticket.html in an overloaded ticket_preview.html.

fixes #418.

#10 @nacin
4 years ago

In revisiting this, I came up with a fairly elegant (low maintenance) way to fix it.

Fun fact, we actually rearrange the order of the fields in the ticket box. It wasn't as noticeable, but they used to revert to the default Trac order when a preview is run. :-)

#11 in reply to: ↑ 9 @adamsilverstein
4 years ago

Thanks for fixing this @nacin!

Note: See TracTickets for help on using tickets.