WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 6 months ago

Last modified 6 months ago

#4236 closed enhancement (fixed)

Support: In short guidelines for review writing, mention that links aren't tolerated

Reported by: tobifjellner Owned by: clorith
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

The moderators generally blanket-remove reviews that contain links.
In the short guideline that is shown on the page when somebody leaves a review, it should be mentioned that, in general, reviews should not include links.

I guess this needs to be added in the forum settings for both:

  • plugin reviews, and
  • theme reviews

See attached screenshot for a clearer understanding at where I'm aiming. (I guess this is just a simple configuration task...)

Attachments (1)

2019-03-04 (4).png (15.7 KB) - added by tobifjellner 7 months ago.

Download all attachments as: .zip

Change History (23)

#2 @Otshelnik-Fm
7 months ago

Agree. Now the moderators just delete the review. Although it was sufficiently deployed and did not pursue the purpose of placing links. And the link led to the website of the plugin
example https://wordpress.org/support/topic/wp-recall-%d1%81%d1%83%d0%bf%d0%b5%d1%80-%d0%bf%d0%bb%d0%b0%d0%b3%d0%b8%d0%bd/?view=all#topic-11269127-replies

This ticket was mentioned in Slack in #forums by otshelnik-fm. View the logs.


7 months ago

#5 @jdembowski
6 months ago

The majority of the links are, to be honest, to obtain traffic and that's the nicest euphemism for spam I can find. That does not just have to be for the reviewer's site and links to the plugin or theme's site is the same thing.

If someone's review is removed they get an @ reply that is also archived. They are invited to leave another review without the links. It's not a great imposition for them to do that and the notification system does send out a note to the reviewer about that.

Please be aware that the majority of the people seeking traffic never post again. Their purpose was not to leave a review, it was to get a link. They're not a "lost opportunity". The forums get some fantastic link magic and the people who do that are aware.

#6 follow-up: @Otshelnik-Fm
6 months ago

add noindex nofollow - no problem?

#7 in reply to: ↑ 6 @jdembowski
6 months ago

Replying to Otshelnik-Fm:

add noindex nofollow - no problem?

It's a problem and noindex nofollow just wastes time IMHO. That does nothing for educating the user or correcting their bad intentions*.

No one needs a link in a review to the plugin or authors site. That's completely unnecessary; you have a plugin or theme page for that.

No one needs to say "Hey, see this site <LINK> for an example" either because the reviews are not about traffic or getting visitors even from the review. There used to be a sub-forum called Your WordPress and it was almost all WordPress link spam. It was closed for that reason.

Reviews are about a user's experience and that needs to be limited to their words. They do not need to post links in reviews. In the rare case that a review makes sense such as to a github issue then that does get permitted. But links to anything else isn't for the reivews.


*Bad intentions as in getting traffic or using the reviews to showcase . When plugin or theme authors ask their users to use the reviews as a showcase, those reviews get archived and the plugin or theme author is asked to stop doing that.

Last edited 6 months ago by jdembowski (previous) (diff)

#8 follow-up: @Howdy_McGee
6 months ago

I agree that review shouldn't need links, examples or otherwise, to get their point across. Eventually that link will more than likely become irrelevant as the site changes and updates. It should be clear to the submitting user though that they should be descriptive since links are not acceptable.

Would it be possible to check for links before allowing the user to submit or update reviews and spit out a message to the user?

#9 in reply to: ↑ 8 @jdembowski
6 months ago

Replying to Howdy_McGee:

Would it be possible to check for links before allowing the user to submit or update reviews and spit out a message to the user?

That's technically possible but I don't think it's necessary. Out of 1,200 reviews I get between 1 to 5 reviews with links.

*Does quick maths*

Aren't numbers wonderful? That's nothing. ;) I don't think this needs overthinking. Just a sentence or two on the review submission form should do it. The primary reason this comes up is when a plugin or theme author asks. The reviewer hardly ever asks.

I know to the plugin or theme author feel that the reviews belong to them and are hard won, but they are for the community and don't belong to them. Hard won, yes. Owned by them? No.

They're not owned by me either but forum moderators do their tasks and reviews are part of that.

#10 follow-up: @Otshelnik-Fm
6 months ago

In the short guideline that is shown on the page when somebody leaves a review, it should be mentioned that, in general, reviews should not include links.

This is it difficult to add to the rules?

to reviewer did not get into a situation when it is marked in read only, and review was removed

#11 in reply to: ↑ 10 @jdembowski
6 months ago

Replying to Otshelnik-Fm:

This is it difficult to add to the rules?

to reviewer did not get into a situation when it is marked in read only, and review was removed

I don't think it needs to go into a rules but yes, I do think there should be a sentence added to the submission form for reviews. Something like this.

"Please do not add links to your review, keep the review about your experience in text only."

In your case the reviewer did receive a note from the moderator, which was myself. They could have easily submitted a new review without the link.

You 100% know that because you either got the same notification or they told you about it. After all, you went to the #forums Slack to complain that I archived the review with a note. You personally confirmed that notifications work and that the user could have simply resubmitted the review without the link.

The FAQ could be updated though but the rules were recently slimmed down from the great wall of words that they became in the past.

#12 follow-up: @Otshelnik-Fm
6 months ago

users leave a review once-it is difficult for them. The second chance (to republish the review without reference) reduces the probability of orders of magnitude

#13 in reply to: ↑ 12 @jdembowski
6 months ago

Replying to Otshelnik-Fm:

users leave a review once-it is difficult for them. The second chance (to republish the review without reference) reduces the probability of orders of magnitude

No, that just is not at all true. I'm sorry you disagree but a few things.

  • That user left a review as requested or with your knowledge. You demonstrated that that is true.

There is nothing wrong with that and to be honest, I will always support any plugin or theme author who just asks for reviews politely without any offers in return. That remains the best and most successful way to get reviews. Just ask politely without being pushy about it.

Don't nag, don't use repeat notifications, etc. Just ask politely for their feedback. It works so well when plugin or theme authors do that.

  • The user received a notification about why their review was archived. There was nothing in the dark, hidden about this. They were able submit a review once, they could just as easily do so again.

It's not a big deal and the few reviews on that plugin show that sort of interaction. That's fine: getting that feedback is important and again, there is nothing wrong with asking for that feedback. Asking for feedback is encouraged.

Reviews are just feedback from users to volunteers. In this case the volunteers are the plugin or theme author. Anyone who is trying to use those reviews for anything else such as business related is making a huge mistake.

#14 follow-up: @Otshelnik-Fm
6 months ago

That user left a review as requested or with your knowledge. You demonstrated that that is true.

it's not true. https://yadi.sk/i/Zn8N-c1k9vwR_Q I subscribed to this plugin or to reviews. That's why I found out about this situation. When I received a notification in the mail-link returned me 404-d. And only a fool would not guess that the review was removed.

I have nothing to do with encouraging the user to review. You're wrong to accuse me of encouraging clients to review. Look at the frequency of reviews for this plugin - there would be a stimulation of ratings would be more.

I am opposed to the moderator removed the review - he can just erase the link. It is a pity that you do not understand

#15 in reply to: ↑ 14 @jdembowski
6 months ago

Replying to Otshelnik-Fm:

Doesn't your link demonstrate that the notifications worked and that the user who left the review received the same message? Do you not understand that part of that is to educate the user as well?

That's a serious question. You do not like the outcome, I get that. But the user did something that they needed to be educated about and I did that.

I'm sorry you do not like the choice I made but there are many reviews to look at and review. Archiving the review was simply efficient while informing the user. That's my choice and other moderators can and sometimes do it differently. Both moderation actions are acceptable and doesn't change anything about reviews: users should not use the reviews for links.

In that specific case it was restored with an edit. In another case just today, someone left 10 consecutive reviews spaced about 5 minutes apart with a link to their site. That's spamming. The reviews were also archived and the user was banned. Are you suggesting I edit the links and let that pass? No. A choice was made how to deal with that just as it was for the review you linked to.

This is all very interesting conversationally but is well past the point of this ticket.

I proposed that the form for submitting reviews be updated with a sentence to ask the user to not use links in reviews. Something like this.

"Please do not add links to your review, keep the review about your experience in text only."

The FAQ can also be updated with some small amount of verbiage.

https://wordpress.org/support/forum-user-guide/faq/

I don't think it needs an 800 word essay but a sentence or two can help clear this up.

#16 @Otshelnik-Fm
6 months ago

Do you not understand that part of that is to educate the user as well?

We all know that:

users leave a review once-it is difficult for them. The second chance (to republish the review without reference) reduces the probability of orders of magnitude

users should not use the reviews for links.

where would he find out?

someone left 10 consecutive reviews spaced about 5 minutes apart with a link to their site. That's spamming.

I agree - linearly, the frequency of the reviews, it is evident

I proposed that the form for submitting reviews be updated with a sentence to ask the user to not use links in reviews.

100% agree

This ticket was mentioned in Slack in #forums by yui. View the logs.


6 months ago

#18 @tobifjellner
6 months ago

  • Owner set to clorith
  • Status changed from new to assigned

#19 @SergeyBiryukov
6 months ago

@Clorith Does this wording of the notice suggested in comment:10 look good to you?

"Please do not add links to your review, keep the review about your experience in text only."

#21 @SergeyBiryukov
6 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 8434:

Support Forums: Add a notice to discourage review authors from adding links to their review.

Props jdembowski, Clorith, tobifjellner.
Fixes #4236.

#22 @SergeyBiryukov
6 months ago

In 8435:

Support Forums: Add missing text domain for a string added in [8434]

See #4236.

Note: See TracTickets for help on using tickets.