WordPress.org

Making WordPress.org

Opened 6 months ago

Closed 6 months ago

#4246 closed defect (duplicate)

PHPDoc missing & hover underline break in wp user profile

Reported by: BharatKambariya Owned by:
Milestone: Priority: high
Component: General Keywords: has-patch
Cc:

Description

PHP Doc Missing:
--added @return bool in disable_group_activity_reporting()
--added @return array in wcorg_close_comments_for_post_types()
--added @return string in wporg_themes_embed_template()

Hover Underline break:
--WordPress user name hover design issue. When hover over wp user name that time underline is breaking at @ point.

Here is the video: https://drive.google.com/file/d/1pa_a5wUZZIY8pPtY5RmQO-h3EywWO_cR/view

Attachments (3)

#4246.diff (2.6 KB) - added by BharatKambariya 6 months ago.
before-profile.png (29.3 KB) - added by BharatKambariya 6 months ago.
after-profile.png (28.5 KB) - added by BharatKambariya 6 months ago.

Download all attachments as: .zip

Change History (5)

#1 @immeet94
6 months ago

  • Priority changed from normal to high

#2 @dd32
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Changing text-decoration-skip-ink: none; globally is not an option, and I'm going to revert #4233 for a more specific fix.

Please submit a patch/ticket per area affected too, A patch which alters WordPress.org, WordCamp.org, profiles.wordpress.org, and WordPress.org/themes isn't generally very useful when those changes are not related.

Additionally, low-effort patches which add little benefit to the code are not worth the time to commit, I can see from the function description that it accepts $post_types

I'm going to close this as a duplicate of #4233 as that's the main intention of this ticket. For the documentation issues, please submit them as new tickets if the documentation can be improved at all.

Note: See TracTickets for help on using tickets.