WordPress.org

Making WordPress.org

Opened 5 months ago

Closed 5 months ago

#4587 closed defect (invalid)

New ZIP for downloading new version of plugin not being generated

Reported by: zookatron Owned by:
Milestone: Priority: high
Component: Plugin Directory Keywords:
Cc:

Description

On the https://wordpress.org/plugins/mybookprogress/ plugin, a new ZIP for download the new version of the plugin is not being generated when an update is submitted via the SVN repository.

Expected behavior: You go to https://wordpress.org/plugins/mybookprogress/, click the "Download" button, and you receive a ZIP file with the new version 1.0.5 files in it.

Actual behavior: You go to https://wordpress.org/plugins/mybookprogress/, click the "Download" button, and you receive a ZIP file with the OLD version 1.0.4 files in it.

This is especially weird because the WordPress Directory recognizes the new 1.0.5 version that was pushed up, it says the most recent version is 1.0.5 right on the plugin page at https://wordpress.org/plugins/mybookprogress/. But if you try to download the files it gives you the previous version. This means that people are getting prompted to download the new version of the plugin in their WordPress dashboards, but when they update it it just downloads the 1.0.4 files, and because of this the prompt to update the plugin will never go away.

We have tried updating the plugin to a new version (1.0.6) and back again, just to see if that would help trigger the ZIP file to regenerate, but it has not helped. This has been going on for several days without any change, so it does not appear to be a temporary glitch in the ZIP file generation system.

Change History (1)

#1 @Otto42
5 months ago

  • Resolution set to invalid
  • Status changed from new to closed

The ZIP file downloads as 1.0.5. Not sure what you're getting, but no issues I can find here.

Note: See TracTickets for help on using tickets.