WordPress.org

Making WordPress.org

Opened 15 months ago

Last modified 4 months ago

#4649 reopened defect

Remove content hiding mechanism on make.wordpress.org

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: low
Component: Make (Get Involved) / P2 Keywords: seo
Cc:

Description

On pages like https://make.wordpress.org/community/2018/02/15/potential-addition-of-a-new-onboarding-team/, the #content container loads with a display: none attribute. This is removed by JS when the page is loaded.

This functionality should be removed, as it's harmful for SEO.

Change History (10)

#1 @jonoaldersonwp
15 months ago

  • Component changed from WordCamp Site & Plugins to Make (Get Involved) / P2

#3 @dd32
15 months ago

Is this a functionality of the upstream breath/o2 theme/plugin?

#4 @dd32
11 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid as this is how the O2 software works. If a change is wanted, that needs to be reported and fixed in the upstream project (We will not be reinventing the wheel on dotorg).

#5 @jonoaldersonwp
11 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

As in previous scenarios, I disupte that this is invalid simply because the problem is 'upstream'. O2 caters for many users, with many different preferences, and many different scenarios. Scoping a universal solution for all of them is an enormous project. Implementing a local solution for our needs is easier. This isn't reinventing the wheel, it's being pragmatic around how we find opportunities to achieve something remotely resembling best practice on dot org, without having to move mountains to do so.

#6 @dd32
11 months ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

As stated, this is a core part of the o2 software we've chosen to use, and at this stage we're not going to change this at all.

#7 @jonoaldersonwp
11 months ago

We chose to use it without an understanding of the negative impact it'd have on our SEO. Now that that's apparent, I don't think it's unrealistic to challenge that choice.

That said, I understand that it'd be a significant undertaking to rip it out and replace it, so, why don't we just apply the laughably tiny fix I've suggested?

It's also pretty apparent that O2 isn't maintained. See https://github.com/Automattic/o2/issues.

So, we can ignore this whilst the site haemorrhages indefinitely, or, we can apply some small patches to fix it locally for us.

E.g., we could overwrite the 'hiding' behaviour by simply adding the following CSS.

#main #content { display: block; }

That might lead to a little bit of jank as the JS kicks in and hydrates the post, but, it'd address part of the immediate problem.

I'd be happy to spec up a bunch of small changes like this (like linking the post title without JS), which we could ship with minimal effort.

#8 @jonoaldersonwp
10 months ago

This remains a serious issue and needs addressing.

#9 @jonoaldersonwp
4 months ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Revisiting this, as:

  • It's still a huge problem.
  • O2 is obviously a dead project.
  • This is also an accessibility nightmare.

I suggest that we either need to:

  • Replace O2 with a more suitable solution, or;
  • Apply some remedial CSS/JS to adjust some of the offending behaviour.

#10 @dd32
4 months ago

o2 is not dead, although I can see why you'd think so.

Please suggest/work on a way to fix this with o2 directly rather than a WordPress.org-specific change. I will happily help make any viable changes in o2 happen, but for that this needs to move to an o2 Issue.

Note: See TracTickets for help on using tickets.