WordPress.org

Making WordPress.org

Opened 14 months ago

Closed 5 months ago

#4658 closed enhancement (wontfix)

String Translator should stay string translator even if PTE correcting things

Reported by: Travel_girl Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords: 2nd-opinion
Cc:

Description

Currently, if the string translator submit a translation and the person who approve the string, but change something in the string (like adding a dot, minus, letter,...) the ownership and credits for translating the string changes to the PTE/GTE. Especially for new translators this can be a bit frustrating.

For an better onboarding experience it should be possible, that a string translator should be visible as the string translator, even if the PTE/GTE adds or changes little things. This would be encourage new translators to keep translating.

If the string needs more corrections, the PTE could change the ownership to his own.

Probably we will need a discussion how much can be changed, that the string translator stays string translator.

Change History (7)

This ticket was mentioned in Slack in #polyglots by tobifjellner. View the logs.


14 months ago

#2 follow-up: @knutsp
14 months ago

I can confirm this is a real frustration and a dilemma, not of the highest order, but still.

Simple solution, when GTE/PTE is editing:

  • Add checkbox for keep original contributor as author

Best solution:

  • Add three radio buttons for author: Auto | Original | Me

where Auto causes a function like similar_text to calculate the percentage of difference for selecting current user (PT/GTE) or the original contributor. This must ceck the original entry, not just the current, when editing a current string. The percentage must be somewhere between 50% and 99%, and need some experimenting.

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


13 months ago

#4 in reply to: ↑ 2 @Travel_girl
13 months ago

Replying to knutsp:

Simple solution, when GTE/PTE is editing:

  • Add checkbox for keep original contributor as author

Thats a great idea! I had something similar in mind!

#5 @casiepa
12 months ago

For some locales there is a 'mentoring' process where a GTE or experienced (global) PTE will validate all strings that are correct and then indicate the translator what needs a change (by e.g. putting them to fuzzy). In that way the translator keeps the credits of their translations.
If as GTE you correct the dots yourself, the translator will never know and make the same mistake again next time.

#6 @tobifjellner
12 months ago

  • This suggestion is well meant, but would create additional, unnecessary administration.
  • How do we decide what is a "small change"?
  • If the translator gets credit even for strings where the editor needs to make one or several changes, why even try to "get it right"?

In my view, much more important is to facilitate feedback to the translator, so that they can learn from their mistakes and do it better next time.

#7 @dd32
5 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

The original request here should be reported to GlotPress as a potential enhancement - GlotPress on GitHub.

#4518 can continue the discussion around feedback to the translation submitter.

I'm going to close this ticket since the changes would be required deeper into GlotPress than I'm comfortable making on Translate.WordPress.org.

I think GTE's also deserve some credit for work that is done to correct mistranslations, even if it's only adding a . or ,.

Note: See TracTickets for help on using tickets.