WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 5 weeks ago

Last modified 5 weeks ago

#4665 closed defect (fixed)

p2 Breathe theme comment form is broken on narrow screens

Reported by: poena Owned by: coffee2code
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: reported-upstream has-patch needs-testing has-screenshots
Cc:

Description

The p2 Breath theme comment form is broken on narrow screens.

The first problem seems to arise at 640 pixels width.

When adding the first comment:
The border around the textarea is no longer visible, and the textarea itself
changes position and floats upwards.

When replying to a post that already has comments or directly to a comment:
The border around the textarea is no longer visible, and the textarea itself
changes position and floats upwards.
With the new position, the input field overlaps the content of the previous comment.

Tested on:
Huawei P20
Desktop, windows, Chrome version 76.0.3809.100

Attachments (2)

first-comment.gif (438.0 KB) - added by poena 3 months ago.
When adding the first comment
additional-comment.gif (392.4 KB) - added by poena 3 months ago.
When adding an additional comment

Download all attachments as: .zip

Change History (7)

@poena
3 months ago

When adding the first comment

@poena
3 months ago

When adding an additional comment

#1 @poena
3 months ago

  • Keywords needs-patch added
  • Summary changed from p2 Breath theme comment form is broken on narrow screens to p2 Breathe theme comment form is broken on narrow screens

#2 @audrasjb
3 months ago

  • Keywords has-patch needs-testing has-screenshots added; needs-patch removed

Hi @poena,

I can reproduce the bug on my side, on both w.org, on a fresh o2 install and on our agency internal o2 version.

Looks like an o2 plugin issue.
I suggested a pull request on Automattic o2 GitHub repository: https://github.com/Automattic/o2/pull/171

Cheers,
Jb

This ticket was mentioned in Slack in #meta by audrasjb. View the logs.


8 weeks ago

#4 @coffee2code
5 weeks ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 9206:

Breathe: Fix responsiveness of comment form at <640px.

Issue has been reported upstream to o2.

Props audrasjb, poena.
Fixes #4665.

#5 @coffee2code
5 weeks ago

  • Keywords reported-upstream added

@audrasjb: Thanks for reporting this upstream. Who knows how long it'll take to get fixed there, so I've gone ahead and patched this locally.

Note: See TracTickets for help on using tickets.