WordPress.org

Making WordPress.org

Opened 2 weeks ago

Closed 13 days ago

#4724 closed defect (duplicate)

Forums: Users Reply list includes posts on archived threads

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

If a thread is archived, it's no longer visible and people can't visit it. This is true of all the sub-posts in the thread.

However if you go to https://wordpress.org/support/users/NAME/replies/ you will see the posts.

https://wordpress.org/support/topic/ignore-this-testing/?view=all - This has been archived.

https://wordpress.org/support/users/ipstenu/replies/ shows my reply

https://wordpress.org/support/users/macmanx/replies/ shows James' reply (Thank you James)

Recommendation: We check "If the parent is archived, treat the reply as archived"

NB: This is a problem because we often archive large threads in order to rein in bad behavior, and this could inadvertently reveal how badly someone is really acting.

Attachments (1)

Screen Shot 2019-09-06 at 3.16.34 PM.jpg (158.9 KB) - added by Ipstenu 2 weeks ago.
Screenshot showing the visible reply to an archived topic (taken as a LOGGED OUT user)

Download all attachments as: .zip

Change History (2)

@Ipstenu
2 weeks ago

Screenshot showing the visible reply to an archived topic (taken as a LOGGED OUT user)

#1 @SergeyBiryukov
13 days ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2504.

Note: See TracTickets for help on using tickets.