WordPress.org

Making WordPress.org

Opened 2 months ago

Closed 5 weeks ago

Last modified 5 weeks ago

#4727 closed enhancement (fixed)

Remove Upload Your Theme button from the header

Reported by: dingo_d Owned by: dd32
Milestone: Priority: high
Component: Theme Review Keywords:
Cc:

Description

Currently, there is a 'Upload Your Theme' button next to the 'Commercial Themes' button that displays when you go to https://wordpress.org/themes/

We suspect that this might be the cause of people updating duplicates to the themes directory.

Plugins page (https://wordpress.org/plugins/) looks much better (maybe because is newer and built with React) and maybe we can make this a bit more uniform. Also putting the upload theme in the bottom would be great.

This patch removes the Upload Your Theme button from the header and adds a widget area with some additional information (including the upload theme button), similar to how plugins page looks like.

Attachments (2)

wporg-themes.png (414.2 KB) - added by dingo_d 2 months ago.
Preview of the widgets area with the upload link
4727.diff (5.1 KB) - added by dingo_d 2 months ago.
Patch with the proposed changes

Download all attachments as: .zip

Change History (10)

@dingo_d
2 months ago

Preview of the widgets area with the upload link

@dingo_d
2 months ago

Patch with the proposed changes

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


2 months ago

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


2 months ago

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


8 weeks ago

#4 @Otto42
8 weeks ago

  • Owner dd32 deleted

#5 @dd32
5 weeks ago

  • Owner set to dd32
  • Status changed from assigned to accepted

#6 @dd32
5 weeks ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 9196:

Theme Directory: Remove the Upload link from the header, and replace it with a set of footer widgets.

Props dingo_d, dd32.
Fixes #4727.

#7 @dd32
5 weeks ago

In 9197:

Theme Directory: Cachebust after [9196].

See #4727.

#8 @dd32
5 weeks ago

  • Keywords has-patch dev-feedback removed

Seems like a reasonable solution, @dingo_d I've gone ahead and implemented it mostly as is.

The main changes were:

  • Combining strings in the footer widgets so that it's properly translatable
  • Moving it to it's own template part
  • Hiding the footer widgets on singular views (ie. /theme/$themename/). My reasoning for that is that this is information that's more useful on the "homepage" rather than detail screens.

Lets see what impact this change has, we can iterate on it as needed.

Note: See TracTickets for help on using tickets.