WordPress.org

Making WordPress.org

Opened 8 weeks ago

Last modified 5 weeks ago

#4877 new defect

Allow Rosetta sites to have HelpHub without forums

Reported by: Nao Owned by:
Milestone: Priority: normal
Component: HelpHub Keywords: needs-patch
Cc:

Description

Currently, HelpHub on Rosetta site only works partially if that site doesn't have forums.

Issue 1

HelpHub user management is supposed to be done from the front end using the user's profile page:
https://ja.wordpress.org/support/users/matt/

However, this profile page does not exist if the site doesn't have forums, even if HelpHub is [e (https://ve.wordpress.org/support/users/matt).

Issue 2

Published HH articles will not receive correct styling.
https://ve.wordpress.org/article/requirements/

---

@audrasjb made this work on FR site, so it'd be great if the same modifications can be made on the following site.

Change History (5)

#1 @YordanSoares
8 weeks ago

@Nao, I think it will be a good idea to have the forum for es_VE to having a channel for talk about related topics of our local community (not for support because es_ES handle very good this and we can redirect people there for get help and bring help to other people as well). This way we "kill two birds with one stone": we fix the issue and add another communication channel.

#2 @cristiano.zanca
7 weeks ago

Hi @Nao , about this
profile page does not exist if the site doesn't have forums, even if HelpHub is [e (https://ve.wordpress.org/support/users/matt)

in Italy we have a similar Helpub profile issue:

if the user has only Helphub role can't access backend and manage Helphub articles

The solution I use by now is make them also Forum Moderator

This ticket was mentioned in Slack in #polyglots by nao. View the logs.


7 weeks ago

This ticket was mentioned in Slack in #polyglots by felipeelia. View the logs.


7 weeks ago

#5 @YordanSoares
5 weeks ago

We have a pending string in the WordPress.org translation project: the URL that redirects to the article to make a backup of database (https://translate.wordpress.org/projects/meta/wordpress-org/es-ve/default/?filters%5Boriginal_id%5D=8791812). I can't redirect to the es_VE related URL because our HelpHub is still having issues. I wonder if you can activate the forum for fix this issue. I think it would be great also having a forum to discuss topics related to our communities, especially translation, meetings and other topics about WP collaboration.

Note: See TracTickets for help on using tickets.