WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 4 months ago

#4974 closed task (fixed)

Upgrade Node.js and npm on the "Build Server"

Reported by: netweb Owned by:
Milestone: Priority: high
Component: General Keywords: pending-systems
Cc:

Description

Previously: #3320 Install the latest Node.js 8.x LTS release on the "build" server

Gutenberg now requires Node.js 12.x and npm > 6.9.x and the "build server" requires updating to accommodate this.

At the time of creating this ticket:

See also: https://github.com/WordPress/gutenberg/pull/19680


Could someone with https://make.wordpress.org/systems/ access create said request above as #prio1 please:.

See previous requests:

Change History (5)

This ticket was mentioned in Slack in #core-js by netweb. View the logs.


8 months ago

This ticket was mentioned in Slack in #core-editor by netweb. View the logs.


8 months ago

This ticket was mentioned in Slack in #meta by netweb. View the logs.


8 months ago

#4 @dd32
8 months ago

  • Keywords pending-systems added
  • Status changed from new to assigned

#5 @coffee2code
4 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed as of 2020-05-01 per follow-up to previously mentioned make/systems request

Version 12.16.3 of node.js and version 6.14.4 of NPM have been deployed to the build infrastructure

Note: See TracTickets for help on using tickets.