WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#4976 closed enhancement (duplicate)

Store i18n errors with the plugin and show onscreen and in API

Reported by: casiepa Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

In Slack the #meta-language-packs channel is getting very valuable information about plugins not being ready for i18n, e.g. 'Missing Text Domain in Header', 'Wrong text domain in header', 'Missing load_plugin_textdomain()', 'Plugin has no readme file', ...
The page on https://translate.wordpress.org/projects/wp-plugins is just indicating a link to Slack, but not the real error message. Not all developers have a slack account.

It would be great for visibility AND support reasons to have the same error messages somewhere on the plugin side after the script has run. Not only on screen (https://translate.wordpress.org/projects/wp-plugins/hello-dolly/) but also in the API. Proposal UTC date and last 5 error messages in the API on https://translate.wordpress.org/api/projects/wp-plugins/hello-dolly/

Attachments (1)

Capture.PNG (82.2 KB) - added by casiepa 9 months ago.
Examples

Download all attachments as: .zip

Change History (3)

@casiepa
9 months ago

Examples

#1 @ocean90
9 months ago

  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from defect to enhancement

Duplicate of #3385.

#2 @casiepa
9 months ago

Ah, didn't remember the ticket! Sorry.
I thought it was just a slack discussion.

Note: See TracTickets for help on using tickets.