WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#5030 closed defect (fixed)

WordCamp activity in Profiles shouldn't say "coming up on [date]" for past dates

Reported by: valentinbora Owned by: dd32
Milestone: Priority: low
Component: Profiles Keywords: has-patch
Cc:

Description

Example:

  • Joined the organizing team for WordCamp Jackson, Michigan 2019 coming up on October 4th
  • Confirmed as a speaker for WordCamp Dayton, OH, USA 2019 coming up on March 1st

These are for last year's WordCamps but the activity says "coming up on [date]", and it doesn't include a year. This can be potentially misleading.

Attachments (1)

5030.diff (2.0 KB) - added by valentinbora 8 months ago.
Remove "coming up on" verbiage for WordCamp activities

Download all attachments as: .zip

Change History (14)

#1 @dd32
9 months ago

The way BuddyPress Activity feeds works is that these are static strings stored in the database, they're not dynamic (although could probably be filtered at display)

Perhaps we should change the strings to just

  • Joined the organizing team for WordCamp Jackson, Michigan 2019
  • Confirmed as a speaker for WordCamp Dayton, OH, USA 2019

#2 @valentinbora
9 months ago

@dd32 makes sense, I feared as much. I appreciate your suggestions.

#3 follow-up: @valentinbora
8 months ago

@dd32 could we instead change sites/trunk/wordcamp.org/public_html/wp-content/plugins/wordcamp-participation-notifier/wordcamp-participation-notifier.php#L360 to provide the full year and maybe even pass along another parameter with the actual timestamp?

#4 in reply to: ↑ 3 @dd32
8 months ago

Replying to valentinbora:

@dd32 could we instead change sites/trunk/wordcamp.org/public_html/wp-content/plugins/wordcamp-participation-notifier/wordcamp-participation-notifier.php#L360 to provide the full year and maybe even pass along another parameter with the actual timestamp?

Oh good the WordCamp side of that is open source :)

Yes, we could pass the full date through, but I was questioning whether including the year/date of the event is remotely useful there, especially with the present/past/future tense issues.

I don't think the date of the event is the important information here, rather it's the action & Event name/link.

@valentinbora
8 months ago

Remove "coming up on" verbiage for WordCamp activities

#5 follow-up: @valentinbora
8 months ago

  • Keywords has-patch added; needs-patch removed

@dd32 apparently not all of it is open source, so I'd love to fix history on the fly through an adaptation of the following:

add_filter( 'bp_activity_get', function( $payload ) {
        if ( !empty($payload['activities'] ) && is_array( $payload['activities'] ) ) {
                foreach ( $payload['activities'] as &$activity ) {
                        if ( 'wordcamp' === $activity->component ) {
                                $activity->action = substr( $activity->action, 0, strpos( $activity->action, 'coming up on' ) );
                        }
                }
        }

        return $payload;
});

This ticket was mentioned in Slack in #meta by valentinbora. View the logs.


8 months ago

#7 in reply to: ↑ 5 @dd32
8 months ago

Replying to valentinbora:

@dd32 apparently not all of it is open source, so I'd love to fix history on the fly through an adaptation of the following:

Not all of profiles.w.org is open-source, Only the activity handler I think.

Rather than using a display filter, I think I'd probably alter the existing DB records directly to remove the unnecessary text.

I'm happy to make this change if we can get some buy-in from a community team member (Just to verify they don't feel that it's an important detail to keep displayed)
edit: Followed up with #community-team on Slack

Last edited 8 months ago by dd32 (previous) (diff)

This ticket was mentioned in Slack in #community-team by dd32. View the logs.


8 months ago

#9 @casiepa
8 months ago

From my side I would say: remove that last part. As there is the link to the WordCamp site, there is no need for the date (what if it suddenly changes or gets canceled?)

#10 @valentinbora
8 months ago

@casiepa, @sippis thanks for chiming in.

@dd32 looks like we have two buy-in confirmations, good enough to proceed?

#11 @SamSuresh
8 months ago

I think it make sense to remove the date since the year is mentioned.

#12 @dd32
8 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 9508:

Profiles: Remove the WordCamp date from the Profiles activity feed.

This keeps the WordCamp name and year, but removes the "Coming up on Feb 30th" verbiage which is incorrect for all previous events.

Props valentinbora.
Fixes #5030.

#13 @dd32
8 months ago

Existing activity items updated too.

Note: See TracTickets for help on using tickets.