WordPress.org

Making WordPress.org

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#5184 closed defect (reported-upstream)

Homepage requests with a 'page' parameter should return a 404

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: lowest
Component: General Keywords: seo
Cc:

Description (last modified by dd32)

Requests like https://wordpress.org/page/3/ should return a 404 template and HTTP header.

Requests to paginated states of /download/, like https://wordpress.org/download/6/, should return a 404 template and HTTP header.

Requests to paginated states of pages in (and including) the 'about' section, such as https://en-gb.wordpress.org/about/features/5/, https://en-gb.wordpress.org/about/5/ and https://wordpress.org/about/license/8/ should return a 404 template and HTTP header

Change History (16)

#1 follow-up: @dd32
19 months ago

Would it returning a canonical tag of https://wordpress.org/ suffice here? (Currently it returns <link rel="canonical" href="https://wordpress.org/3/" />)

#2 @dd32
19 months ago

  • Description modified (diff)

Closing the others as duplicates of this, as they're all Paginated states of Pages which is the same thing at the core.

#3 @dd32
19 months ago

#5185 was marked as a duplicate.

#4 @dd32
19 months ago

#5186 was marked as a duplicate.

#5 follow-up: @ocean90
19 months ago

The last two examples should be fixed by [WP47727].

#6 in reply to: ↑ 5 @dd32
19 months ago

Replying to ocean90:

The last two examples should be fixed by [WP47727].

Ah, so they are, Thanks @SergeyBiryukov!

#7 in reply to: ↑ 1 ; follow-up: @bradleyt
19 months ago

Replying to dd32:

Would it returning a canonical tag of https://wordpress.org/ suffice here? (Currently it returns <link rel="canonical" href="https://wordpress.org/3/" />)

Just noting that core should really be returning a canonical of either https://wordpress.org/page/3/ or https://wordpress.org/ here - https://wordpress.org/3/ is just plain wrong. This specific canonical issue only happens on the homepage, and there is an open core ticket for this specific issue: https://core.trac.wordpress.org/ticket/49220

For wordpress.org specifically, the canonical should be equal to https://wordpress.org/

#8 in reply to: ↑ 7 @dd32
19 months ago

Replying to bradleyt:

Replying to dd32:

Would it returning a canonical tag of https://wordpress.org/ suffice here? (Currently it returns <link rel="canonical" href="https://wordpress.org/3/" />)

...
For wordpress.org specifically, the canonical should be equal to https://wordpress.org/

Would returning that canonical tag fulfil the needs of this ticket, specifically, can we avoid having to return a 301 or 404 here and just use the canonical tag instead?

#9 follow-up: @jonoaldersonwp
19 months ago

A canonical tag would definitely help, but we'd still be in a position where we have infinite crawl traps and pages which should exist. That'd continue to impact crawl budget, discovery, etc, across the site(s).

#10 in reply to: ↑ 9 @dd32
19 months ago

Replying to jonoaldersonwp:

we'd still be in a position where we have infinite crawl traps and pages which should exist. That'd continue to impact crawl budget, discovery, etc, across the site(s).

As paginated states of the front-page aren't ever actually linked, I'm not sure if that's realistically an issue here? 3rd party websites may link to one or two such pages, but on the whole it shouldn't be massive traffic?

#11 @jonoaldersonwp
19 months ago

The problem isn't traffic volume, it's that they're queryable and public. That means they'll still represent a point of leakage. That aside, they shouldn't exist / be exposed, regardless.

#12 @dd32
19 months ago

  • Resolution set to fixed
  • Status changed from new to closed

https://wordpress.org/page/3/

Returns a canonical tag now.
I'm not inclined to add a redirect here right now.

All other urls mentioned redirect thanks to [WP47727].

#13 @jonoaldersonwp
19 months ago

  • Priority changed from normal to lowest
  • Resolution fixed deleted
  • Status changed from closed to reopened
Last edited 19 months ago by jonoaldersonwp (previous) (diff)

#14 @dd32
19 months ago

Unless core fixes those, these won't be returning 404's on WordPress.org.

#15 @dd32
19 months ago

  • Resolution set to reported-upstream
  • Status changed from reopened to closed

Opened https://core.trac.wordpress.org/ticket/50163 with a possible patch.

Going to mark this as it can be handled upstream.

#16 @jonoaldersonwp
19 months ago

Nice one, thanks! :)

Note: See TracTickets for help on using tickets.