WordPress.org

Making WordPress.org

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#5230 closed enhancement (fixed)

Screenshots for plugins in mobile doesn't work well

Reported by: anjanphukan Owned by: dufresnesteven
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hi,

I have been found this issue from ling time. In your website wordpress.org when I search any plugin and go to screenshots section, then try to navigate them with arrows from my mobile it doesn’t work well. If I tap the arrow it slides two screenshots at a time. Same for the previous arrow too. Is this some kind of issue you need to fix in wordpress.org website?

Attachments (1)

5230.diff (1.1 KB) - added by dufresnesteven 17 months ago.
It's happening because both the touch event & click event are firing. This patch removes the touch event. I'm not certain why it would be necessary. I'm curious if anyone thinks we need to keep it.

Download all attachments as: .zip

Change History (6)

#1 @dufresnesteven
17 months ago

Hi @anjanphukan, thanks for taking the time to file a ticket! I was able to reproduce the issue.

We'll look into it and keep you updated!

@dufresnesteven
17 months ago

It's happening because both the touch event & click event are firing. This patch removes the touch event. I'm not certain why it would be necessary. I'm curious if anyone thinks we need to keep it.

#2 follow-up: @dd32
17 months ago

I'm curious if anyone thinks we need to keep it.

I'm assuming it was there as touches weren't triggering clicks, or maybe swiping actions weren't triggering clicks?

I think pointer events are supposed to replace those, but click makes more sense here.

Assuming that on some older platform that click wasn't being triggered for touch events, I would expect supporting modern clients is more important than those.

#3 in reply to: ↑ 2 @dufresnesteven
17 months ago

Replying to dd32:

I'm assuming it was there as touches weren't triggering clicks, or maybe swiping actions weren't triggering clicks?

I think pointer events are supposed to replace those, but click makes more sense here.

Assuming that on some older platform that click wasn't being triggered for touch events, I would expect supporting modern clients is more important than those.

I came to the same conclusions.

I'll apply the patch and we can reassess the approach should any issues arise in the future.

#4 follow-up: @dufresnesteven
17 months ago

  • Owner set to dufresnesteven
  • Resolution set to fixed
  • Status changed from new to closed

In 9928:

Plugins: Remove touchStart event handler from screenshot carousel to fix mobile double click.

Props anjanphukan.
Fixed: #5230

#5 in reply to: ↑ 4 @anjanphukan
17 months ago

Replying to dufresnesteven:

In 9928:

Plugins: Remove touchStart event handler from screenshot carousel to fix mobile double click.

Props anjanphukan.
Fixed: #5230

Great! It looks liked fixed to me. Thank you.

Note: See TracTickets for help on using tickets.