WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 3 months ago

#5921 closed defect (invalid)

GlotPress does not keep the sort after saving a record

Reported by: psmits1567 Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

If you set a different sort then default, the sort is not applied after saving several records with untranslated lines between them.
Set sort to "Original string" "Ascending"

  1. Pay attention to the position of the original in the list
  2. Translate the first line, and save it
  3. Check where it ended in the list
  4. Leave untranslated lines between, and translate the next line
  5. Check where it ended in the list (most of the times it ends up one lower
  6. Repeat this several times.
  7. Check where the translation ends up in the list

Remarks

  1. After the translation check the sort you selected. This appears to be the same, so the setting does not get lost.
  2. Specially at the end of the list, I have seen an error "hasClass"

So maybe if the sorting is handled properly, this might solve the "hasClass" error.

Change History (3)

#1 follow-up: @tobifjellner
3 months ago

Just to isolate: Did you try this also with GlotDict disabled?

#2 in reply to: ↑ 1 @Webaxones
3 months ago

Replying to tobifjellner:

Just to isolate: Did you try this also with GlotDict disabled?

…or WP Translation Filler or WPGPTools

#3 @psmits1567
3 months ago

  • Resolution set to invalid
  • Status changed from new to closed

After disabling all addons, the problem is gone.
Oddly it appears to be caused by WP Translation Filler.
So the ticket can be closed.

Note: See TracTickets for help on using tickets.