WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#593 closed task (fixed)

WCSF ticketing test

Reported by: jenmylo Owned by:
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords:
Cc:

Description

This is an umbrella ticket to capture bug reports from people who are buying WCSF tickets early as part of our new ticketing ux test. @iandunn will be taking care of any fixes before opening ticket sales to the general public.

Reporters: Leave a comment on this ticket describing what happened, and please identify your report as one of the following.

  1. Prevented you from buying a ticket
  2. Allowed you to buy a ticket, but you don't think it worked right
  3. Allowed you to buy a ticket, you are just commenting on something you thought was awkward

Thanks!

Change History (16)

#1 @aaroncampbell
5 years ago

  1. Allowed you to buy a ticket, you are just commenting on something you thought was awkward

The only thing that was a little annoying was that it wanted me to log into WordCamp.org using my WordPress.org credentials, which means LastPass couldn't fill it for me and now I have two records in LastPass that won't stay synced whenever I change it.

#2 follow-up: @Otto42
5 years ago

@aaroncampbell : ideally we'd have it do a redirect authentication thing, but that's not quite ready yet.

In the meantime, LastPass can handle the case with the equivalent domains feature:
https://helpdesk.lastpass.com/account-settings/equivalent-domains/

#3 in reply to: ↑ 2 @jenmylo
5 years ago

Replying to Otto42:

@aaroncampbell : ideally we'd have it do a redirect authentication thing, but that's not quite ready yet.

In the meantime, LastPass can handle the case with the equivalent domains feature:
https://helpdesk.lastpass.com/account-settings/equivalent-domains/

You totally beat me and posted while I was still typing. You win! :)

#4 follow-up: @alexkingorg
5 years ago

The "remember me" checkbox was a bit wonky in Chrome - it seemed to outline the box rather than putting a checkmark in it. Not sure if it was actually working or not, but I experienced no other issues with checkout.

#5 in reply to: ↑ 4 @iandunn
5 years ago

Replying to alexkingorg:

The "remember me" checkbox was a bit wonky in Chrome - it seemed to outline the box rather than putting a checkmark in it. Not sure if it was actually working or not, but I experienced no other issues with checkout.

That's caused by our janky SSL setup; The request for dashicons.css is being redirected to http://central.wordcamp.org, but Chrome blocks it because it's not over HTTPS. One of our next projects is overhauling the SSL setup, but in the mean time we should be able to tweak the Nginx rule to ignore dashicons. I'll check w/ the systems group.

#6 follow-up: @Otto42
5 years ago

It might make sense to use some of the resources we have over on w.org if this is a problem. We have SSL working (mostly) and the static cache for static resources like this.

https://s.w.org/wp-includes/css/dashicons.css?20140409 is what we're using everywhere on w.org.

#7 follow-up: @_DorsVenabili
5 years ago

  • Cc rocvaltor@… added
  • Priority changed from normal to high

Hi guys! the "Meal preference?" field should not be required, or to add the option "I don't have any meal preference" ;)

Cheers and see you at WCSF! :)

Rocío Valdivia

#8 in reply to: ↑ 7 @aaroncampbell
5 years ago

Replying to _DorsVenabili:

Hi guys! the "Meal preference?" field should not be required, or to add the option "I don't have any meal preference" ;)

I think there was an "omnivore" option, which is basically "I eat whatever"

#9 @_DorsVenabili
5 years ago

  • Cc rocvaltor@… removed
  • Priority changed from high to normal

LOL ok, I'm silly, sorry guys! XD

#10 in reply to: ↑ 6 ; follow-up: @iandunn
5 years ago

Replying to Otto42:

It might make sense to use some of the resources we have over on w.org if this is a problem.

I don't think that'd work, because WordCamp.org runs the latest tag instead of trunk.

#11 follow-up: @Gwendydd
5 years ago

I bought two tickets, and the ticket confirmation process went smoothly. However, at the end of the ticket confirmation process, it didn't really feel very "done" - there was a message in green at the top of the page saying the ticket was confirmed, but it was a long page, so some people might not notice that green message at the top, and the form was still there and fillable. It would feel more complete if it took you to a new page saying, "yay, you're done" or at least disabled all of the form fields so it didn't seem like I could still fill it in again.

#12 in reply to: ↑ 11 ; follow-up: @iandunn
5 years ago

Replying to Gwendydd:

However, at the end of the ticket confirmation process, it didn't really feel very "done" [...] It would feel more complete if it took you to a new page saying, "yay, you're done" or at least disabled all of the form fields so it didn't seem like I could still fill it in again.

It intentionally allows you to make changes any time before the event, in case you change your mind and want a different size t-shirt, different meal preference, etc; or if the ticket changes hands and the new owner needs to change all the info.

I don't think we'd want to disable that, but maybe there's another way to improve it? We could redirect them to a new page, and then just give them a link to edit the form again if they want.

If we do that, though, then the user might not feel as confident that the data was saved correctly, since they can't see it anymore, and there's an extra click if they want to make another change. But it's entirely possible that I'm the only one who's anal-retentive enough to double check that values were saved correctly when entering forms :)

What do you think?

#13 in reply to: ↑ 12 @Gwendydd
5 years ago

Replying to iandunn:

Replying to Gwendydd:

However, at the end of the ticket confirmation process, it didn't really feel very "done" [...] It would feel more complete if it took you to a new page saying, "yay, you're done" or at least disabled all of the form fields so it didn't seem like I could still fill it in again.

It intentionally allows you to make changes any time before the event, in case you change your mind and want a different size t-shirt, different meal preference, etc; or if the ticket changes hands and the new owner needs to change all the info.

I don't think we'd want to disable that, but maybe there's another way to improve it? We could redirect them to a new page, and then just give them a link to edit the form again if they want.

I agree - we don't want to disable the ability to keep editing, but we do need to find a way to make it clear that the changes you just made have been saved.

If we do that, though, then the user might not feel as confident that the data was saved correctly, since they can't see it anymore, and there's an extra click if they want to make another change. But it's entirely possible that I'm the only one who's anal-retentive enough to double check that values were saved correctly when entering forms :)

Nope, you aren't the only person who's that anal-retentive. :) I think it would be best to redirect to a new page that says, "yay, you confirmed your ticket, here's the information you provided on the form. If you want to change it, go here or follow the link in your email."

#14 in reply to: ↑ 10 @Otto42
5 years ago

Replying to iandunn:

I don't think that'd work, because WordCamp.org runs the latest tag instead of trunk.

Well, not for all static resources like the assorted JS files (which change occasionally), but for something like the dashicons CSS and font files, you probably wouldn't have any real issues with one-off replacements like that.

#15 @iandunn
5 years ago

In 839:

SSL Workarounds: Load certain stylesheets from the WordPress.org CDN.

See #593.

#16 @iandunn
5 years ago

  • Keywords reporter-feedback removed
  • Resolution set to fixed
  • Status changed from new to closed

Closing this since WCSF is over.

@jenmylo, please re-open with feedback if you want us to move forward on Morgan's suggestion about some kind of "yay, you're done" message for users.

Note: See TracTickets for help on using tickets.