Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#6327 closed defect (bug) (fixed)

All channels are treated as private groups

Reported by: clorith's profile Clorith Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: Priority: high
Component: Communication (Matrix, Slack, IRC) Keywords:
Cc:

Description (last modified by Clorith)

After r11878, all /here and similar calls are treating the channels as private groups.

This appears to be caused by a missing `$` on line 177, which in PHP <8 only throws a warning, and interprets as true, leading the conditional to pass and set the channel type as privategroup.

Props @annezazu for noticing!

Attachments (1)

6327.patch (1010 bytes) - added by Clorith 2 years ago.

Download all attachments as: .zip

Change History (3)

@Clorith
2 years ago

#1 @Clorith
2 years ago

  • Description modified (diff)

#2 @SergeyBiryukov
2 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 11882:

Slack: Announce: Correct the variable used to determine private channels.

Follow-up to [11878].

Props Clorith, annezazu.
Fixes #6327.

Note: See TracTickets for help on using tickets.