Making WordPress.org

#6353 closed defect (bug) (fixed)

Issue when non-logged in user click on submit photos

Reported by: rafiahmedd's profile rafiahmedd Owned by:
Milestone: Priority: normal
Component: Photo Directory Keywords: reporter-feedback
Cc:

Description

When a non-logged in user click on submit photos the page just reload and do nothing. So there should be some kind of validation if user is logged-in then return to submit page otherwise return him to the login page.

Change History (5)

#1 @rafiahmedd
23 months ago

  • Type changed from feature request to defect (bug)

This ticket was mentioned in Slack in #meta by rafiahmedd. View the logs.


23 months ago

#3 @coffee2code
20 months ago

  • Keywords reporter-feedback added

Hi @rafiahmedd. Thanks for the report! However, I'm unable to reproduce the issue. Could you be more specific about what page you're on that exhibits the problem, and what link you are clicking and what is its destination URL?

The "Submit your photos" link from the front page, and the "Submit" link in the menu bar on all other pages, all link to the submit page. On the submit page, if you're not logged in, you're asked to do so via a "log in or create an account" link (the same URL is used for the "Login" link in the admin bar on that page). That's the proper link to log into wordpress.org and get redirected back to the photo submit page when successful.

Unless you mean that you're on the submit page and you click the "submit" link in the menu bar. In which case, yes, the submit page just reloads with no change because you've chosen to go to the submit page, though you're already on it. That's expected behavior. The underline of the "Submit" link in the menu bar indicates that you are currently on that page. This behavior is the case when you're on any page throughout wordpress.org that appears in any sort of menu navigation.

So some clarification here could help.

#4 @rafiahmedd
20 months ago

@coffee2code thank you for looking into this. I see this issue has been resolved. You may close this ticket.

#5 @coffee2code
19 months ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.