Making WordPress.org

Opened 22 months ago

Closed 15 months ago

Last modified 12 months ago

#6483 closed defect (bug) (fixed)

Update Google Analytics to GA4.

Reported by: dufresnesteven's profile dufresnesteven Owned by:
Milestone: Priority: normal
Component: WordPress.org Site Keywords:
Cc:

Description

Universal Analytics will no longer process new data in standard properties
beginning July 1, 2023. Prepare now by setting up and switching over to a Google
Analytics 4 property.

Relevant Link:
https://support.google.com/analytics/answer/11583528

Change History (19)

#1 @dufresnesteven
16 months ago

@jonoaldersonwp You mentioned that you have GA4 in a ready state.

Can you add any rollout details here for anyone following along?

#2 follow-up: @jonoaldersonwp
16 months ago

Yep, all fairly straightforward!

The GTM container has been updated to include a basic GA4 setup, which includes:

  • The various URL (and title) cleansing rules we have in place for privacy reasons
  • Pageviews
  • Key events (plugin downloads, theme downloads, wp downloads)
  • Site search
  • All of the default 'Enhanced measurement' stuff that GA does (external link clicks, file downloads, history state changes, etc)

We can roll this out in parallel to the existing implementation, and, iterate on it over time; there's some stuff in the UA setup which isn't captured here yet.

Last edited 16 months ago by jonoaldersonwp (previous) (diff)

#3 in reply to: ↑ 2 @dufresnesteven
16 months ago

I'm not sure who is the ultimate decision maker here but our hand is forced anyways, so if we haven't already, I say let's deploy it!

After a month or so, we can check back in and fine-tune.

#4 @jonoaldersonwp
15 months ago

Just need somebody to hit the 'publish' button on the GTM container :)

#5 @dd32
15 months ago

Just need somebody to hit the 'publish' button on the GTM container :)

I have no idea what this means :) I can see a separate property setup in our account called WordPress.org - GA4 but I'm not sure if that's what you're referring to.. since there's no public buttons.. I can also see a new GoogleTagManager setup with the same name, but I don't have access to the existing tag manager used on .org, so I'm not sure if that's the same thing or different.

We also need to migrate the bbpress.org, buddypress.org, Browse Happy, ping-o-mattic, core.trac.wordpress.org and some other misc. UA properties listed in our account.

#7 in reply to: ↑ 6 @dd32
15 months ago

Replying to jonoaldersonwp:

The workspace is here: https://tagmanager.google.com/?authuser=3#/container/accounts/3528490509/containers/9334995/workspaces/69

Thanks, I can confirm none of my Google accounts have access.

#8 follow-up: @jonoaldersonwp
15 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Joost has very kindly sorted this out. Closing!

#9 in reply to: ↑ 8 @dd32
15 months ago

Replying to jonoaldersonwp:

Joost has very kindly sorted this out. Closing!

Did that include:

We also need to migrate the bbpress.org, buddypress.org, Browse Happy, ping-o-mattic, core.trac.wordpress.org and some other misc. UA properties listed in our account.

#10 @joostdevalk
15 months ago

I've just published the container. Will work with @jonoaldersonwp to make sure tracking works in GA4 properly. Will also liaise with @matt to do the same on other sites like bbpress.org and buddypress.org indeed, because that still needs to happen, but he needs to expand my rights a bit for me to be able to handle that.

#11 @ben.greeley
14 months ago

@otto42 or @coffee2code may be able to help expand the rights to upgrade GA4 on the other sites if Matt is unavailable. I believe they are both administrators for the wordpress.org GA organization.

#12 @Otto42
14 months ago

Indeed, we are.

As far as I can tell, Joost has all the same permissions on those containers.

#13 @joostdevalk
13 months ago

Could we make a channel to discuss these things on Slack?

#14 @dd32
12 months ago

In 12647:

Trac: Remove old GTM container.

This removes the GTM code in favour of the WordPress.org-provided GTM via the global header.

Closes https://github.com/WordPress/wordpress.org/pull/153
See #6483.

#15 @dd32
12 months ago

In 12648:

Trac: Update header templates.

See #6483.

#16 @dd32
12 months ago

In 12649:

Trac: Add GTM to the bbPress and BuddyPress instances after [12647].

See #6483.

#17 @dd32
12 months ago

In 12650:

Trac: Use the correct GTM container ID in [12649] for bbPress and BuddyPress.

See #6483.

#18 @coffee2code
12 months ago

In 12654:

Jobs theme: Add GTM.

Props joostdevalk.
See #6483.

#19 @dd32
12 months ago

In 12658:

Trac: Include the HTML tags within the <body> tag for bbPress/BuddyPress trac's.

Followup to [12649].
See #6483.

Note: See TracTickets for help on using tickets.