Making WordPress.org

#6537 closed feature request (wontfix)

Add option to view the under moderation photo queue

Reported by: amitpatelmd's profile amitpatelmd Owned by:
Milestone: Priority: normal
Component: Photo Directory Keywords: needs-patch
Cc:

Description

While uploading the photo to the photos directory, It would be great to have an option of under moderation picture in order to get rid of duplicate or repeat photos in the queue. Because it takes a little longer to approve the moderation queue, and when I submit 5 photos a day, I can't remember if I submitted the photo earlier.

If we provide an option to view our photos in the moderation queue, at least I will know what photos I already submitted.

Change History (7)

#1 @roytanck
16 months ago

Hi @amitpatelmd. Isn't this already in place? When I go to https://wordpress.org/photos/submit/ , that page shows a list of the five images that are currently awaiting moderation. The list includes the filenames and their description. For me, this is sufficient info to avoid duplicate uploads, although thumbnails would perhaps be helpful.

#2 follow-up: @amitpatelmd
16 months ago

Thanks @roytanck.

Yes it shows moderation queue details. It consist of file name, Submission date and caption. But when one same picture is uploaded twice, it is sometimes not easy to check file name since it is auto generated image name from mobile device. So it would be great if we can include thumb or more details to be displayed in queue box if possible. Hope that makes sense.

#3 in reply to: ↑ 2 ; follow-up: @roytanck
16 months ago

Replying to amitpatelmd:

Yes it shows moderation queue details. It consist of file name, Submission date and caption. But when one same picture is uploaded twice, it is sometimes not easy to check file name since it is auto generated image name from mobile device. So it would be great if we can include thumb or more details to be displayed in queue box if possible. Hope that makes sense.

Yes, that makes sense. I have only uploaded images from my camera, which have a short, easy to read filename, so the issue was not immediately obvious to me.

As said, a thumbnail of the image would be nice. And perhaps it would even be possible to implement a check in the upload page that checks the new filename against the queue, so a warning can be displayed if you re-upload the same image. With the number of uploads being increased in #6524, this issue is likely to occur more often.

#4 @coffee2code
16 months ago

In 12231:

Photo Directory, Uploads: Add link to upload form that points to current user's photo archive.

See #6537.

#5 @coffee2code
16 months ago

In 12234:

Photo Directory, Uploads: Add JS pre-upload validation to check if submission has same file name as another pending submission from the contributor.

The check is more of a means to immediately alert contributor to a likely duplicate file submission without having to wait upon submission for the actual duplication check. An identical server-side check for this is unnecessary as the file will be checked for actual duplication.

Props roytanck, coffee2code.
See #6537.

#6 in reply to: ↑ 3 @coffee2code
16 months ago

Due to the way the photos are hosted, we are not able to offer thumbnails of photos prior to approval.

The site does take measures to prevent submission of duplicate content. And as a last resort, moderators will reject photos that are too similar or identical to something you've submitted before or concurrently.

While a thumbnail would certainly be helpful here, we encourage providing an accurate description of the photos with your submissions (which will be shown in the pending submissions table). If that doesn't help to differentiate your photos, then using better descriptions would be helpful (for you and others) or that might mean you're trying to submit photos that are too similar to each other.

If all else fails, just try submitting a photo you're uncertain of. The site should prevent a duplicate submission, and if it doesn't, moderators will prevent the duplicate from being published.

I made an enhancement to add a link to your photos archive on the submit page so that you can easily see your photos that have already been published, which can save you the effort of attempting to resubmit a duplicate of one those photos (which won't get accepted).

#7 @coffee2code
16 months ago

  • Keywords changes-requested removed
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to roytanck:

And perhaps it would even be possible to implement a check in the upload page that checks the new filename against the queue, so a warning can be displayed if you re-upload the same image.

Thanks for the idea! While an actual file duplication check happens once you submit the form, we can check the file name being uploaded against the file names of the contributor's other submissions still in the queue. That should save the unnecessary submission of a likely duplicate. And this would help in the cases brought up by @amitpatelmd, where the local photo file name may not be presented. Implemented in [12234].


But for the original request of showing a thumbnail of the photos in the queue, I'm closing this as wontfix.

Note: See TracTickets for help on using tickets.