Making WordPress.org

Opened 16 months ago

Closed 8 months ago

#6849 closed defect (bug) (invalid)

Code Reference filter not working

Reported by: aezazshekh's profile aezazshekh Owned by:
Milestone: Priority: normal
Component: Developer Hub Keywords: needs-patch has-screenshots
Cc:

Description

There is a filter on the Code Reference page that is not working properly.

Page Link => https://developer.wordpress.org/reference/

Change History (2)

#2 @coffee2code
8 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the report! However, the filters you are referring to relate to the search field just above them. Your video depicts the front page of the Code Reference. The filter checkboxes don't affect that page since those aren't search results. When using the search field just above the checkboxes, you can use the checkboxes to refine the results when submitting the search query.

Also, even when viewing search results, changing the state of the checkboxes won't update the results being shown (i.e. it isn't a dynamic filter). They only apply when your search query gets resubmitted.

The new upcoming theme for the site does not present the filter checkboxes on the front page of the Code Reference, so there should be no confusion there. And while the filters (which aren't quite checkboxes) are still not dynamic, there is an "Apply" link next to them to provide a cue that you have to apply any changes you make to the filters.

Note: See TracTickets for help on using tickets.