Making WordPress.org

Opened 2 months ago

Closed 3 weeks ago

#7463 closed defect (bug) (duplicate)

Encountering 500 error submitting photos to the directory

Reported by: desrosj's profile desrosj Owned by:
Milestone: Priority: normal
Component: Photo Directory Keywords:
Cc:

Description

For the last 24 hours or so, I have been unable to submit a photo to the directory. When submitting the form, it loads for about a minute and then loads /photos/wp-admin/admin-ajax.php showing a white screen.

Looking in the Network tab for my browser, a 500 error is being returned.

These are the response headers, in case they're helpful:

HTTP/3 500 
server: nginx
date: Mon, 12 Feb 2024 17:30:17 GMT
content-type: text/html; charset=UTF-8
strict-transport-security: max-age=3600
x-olaf: ⛄
access-control-allow-origin: https://wordpress.org
access-control-allow-credentials: true
x-robots-tag: noindex
x-content-type-options: nosniff
expires: Wed, 11 Jan 1984 05:00:00 GMT
cache-control: no-cache, must-revalidate, max-age=0, no-store, private
referrer-policy: strict-origin-when-cross-origin
x-frame-options: SAMEORIGIN
x-frame-options: SAMEORIGIN

Change History (6)

#1 @Otto42
2 months ago

Maybe the problem is with the photo you're trying to upload. Because photos are actively being submitted right now. No indications of problems.

#2 @desrosj
2 months ago

I had tried different photos before opening the ticket, but I just tried again with a third photo and it worked.

The first time submitting just now it failed with some type of network related warning. I disabled WiFi and tried again, and the second time succeeded. The other failures showed no network error message.

I'll keep digging to see if I can figure out anything on my end.

#3 @coffee2code
2 months ago

This happens occasionally and usually (from what I've seen) involves a photo needing rotating (or at least the site thinking the photo needs rotating). There's something about certain photos that causes the process to either time out or consume too much memory.

Oddly enough your submission failures did not trigger an error. The only such error in the logs in the last week is from the 10th and not by you. So this might be a different kind of failure? If the site doesn't like a photo, I don't believe it ever likes it on subsequent resubmissions, though we welcome a resubmit to try again (which most people keep doing multiple times anyhow).

Currently this ticket doesn't provide any additional context over two related and open tickets, so I'd normally close this as a duplicate of the oldest of the two (#6142; also see #7163). But I'll leave it open for now if additional investigation results in more context and since this sounds like it might be a different issue.

Feel free to DM me or link the photo and I can investigate as well.

#4 follow-up: @roytanck
4 weeks ago

I ran into this, and noticed that reducing the resolution of the images made them upload perfectly. Initially, I tried uploading images exported from Lightroom at 7500px (the maximum value in the guidelines). I tried two images, and both failed.

When I modified the Lightroom export settings to scale them down to 6000px, both uploaded without issues. All other export settings were the same.

I assume that processing the images allocates a lot of memory, and more so for high resolution images? Perhaps that could be part of the issue?

#5 in reply to: ↑ 4 @coffee2code
3 weeks ago

Replying to roytanck:

I assume that processing the images allocates a lot of memory, and more so for high resolution images? Perhaps that could be part of the issue?

Memory depletion is probably playing a part in most cases. The problem is triggered more often when a photo needs rotation (or the site thinks it needs rotation). Image dimensions may be a factor in part of that equation (as potentially evidenced by you reducing your image's dimensions to get it to upload).

#6 @coffee2code
3 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for this report! General uploading issues are still under investigation. I'm going to close this in favor of the earlier ticket being used to track it, #6142, though I appreciate the extra context provided here.

Note: See TracTickets for help on using tickets.