WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#784 closed defect (worksforme)

WP-CLI build process regularly failing because of throttled (?) WordPress.org requests

Reported by: danielbachhuber Owned by:
Milestone: Priority: high
Component: API Keywords:
Cc:

Description

In the last month or so, WP-CLI's build processes have regularly failed because of (what I believe are) throttled WordPress.org requests.

Here's a classic example of a failed build:

https://dl.dropboxusercontent.com/s/bu3msmxzh53i3x1/2014-12-16%20at%2011.29%20AM.png

The build failed because installing the WordPress importer is a pre-condition of the import tests. Installing the WordPress importer doesn't normally fail — and the problem is almost always fixed by restarting the build.

However, restarting the build on every pull request isn't even a short term satisfactory solution. It's really annoying to have builds failing all of the time because of unrelated issues. I'd prefer not to implement a hack workaround though. What can be done to improve the reliability of our connection with WordPress.org?

Related conversation: https://github.com/wp-cli/wp-cli/issues/1493

Change History (6)

This ticket was mentioned in Slack in #cli by nacin. View the logs.


5 years ago

This ticket was mentioned in Slack in #cli by danielbachhuber. View the logs.


5 years ago

#3 @danielbachhuber
5 years ago

Chatted with Barry some on Skype. Apparently there is some strong correlation between traffic spikes and API failures on WordPress.org right now. He made some changes to hopefully mitigate the API failures. I'll follow up in a few to several days to report whether I've seen any improvements.

#4 @danielbachhuber
5 years ago

This is still a problem. Any ETA as to when there will be new hardware in place?

This ticket was mentioned in Slack in #meta by danielbachhuber. View the logs.


5 years ago

#6 @danielbachhuber
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Barry doubled the servers. This seems to have solved the problem nicely :)

Note: See TracTickets for help on using tickets.