WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#917 closed defect (fixed)

Theme thumbnails flicker on hover

Reported by: Clorith Owned by: obenland
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

When hovering over the thumbnails in the 1st or 2nd column in the new theme directory they seem to resize horizontally within their container by a few pixels then shrink back to the original size.

This doesn't happen on the 3rd column.

Only seems to occur in Chrome 40 (also tested in FF 36 and IE11 where the stutted doesn't happen) on Windows.

It seems to be caused by the transition rule on .theme-browser .theme .theme-screenshot img (themes.css line 150), that gets re-triggered when we apply the overlay to the thumbnail.

Change History (3)

#1 @Clorith
5 years ago

After ab it of testing, I'm not seeing any effect of having the transition rule on this particular selector (perhaps I'm missing something?), so removing it shouldn't be a problem and would solve this, but someone who knows the purpose of the rule might want to chime in.

This ticket was mentioned in Slack in #meta by clorith. View the logs.


5 years ago

#3 @obenland
5 years ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 1413:

WP.org Themes: Prevent thumbnail flicker in Chrome.

This was removed from the wp-admin theme-install screen in [core31316].

Fixes #917.

Note: See TracTickets for help on using tickets.