WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#944 closed defect (worksforme)

Avoid creating new trac tickets unnecessarily

Reported by: obenland Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

Sometimes the uploader creates a new trac ticket when it actually should append a new version to an existing ticket.

Example: https://wordpress.slack.com/archives/themereview/p1425779846001479

Change History (5)

#1 @obenland
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I'm not able to reproduce it. Will see if there's ever another report of this, but reopening a ticket is definitely no the cause.

#2 @Otto42
5 years ago

Once a ticket is closed, then the old sync process would not append to it anymore even if it was a reopened ticket. So, if this is still the case, then that's the same as it was previously.

#3 @obenland
5 years ago

Even reopened tickets pass the empty( $ticket[3]['resolution'] ) && 'approved' !== $ticket[3]['status'] condition though. Status is reopened and the resolution is empty.

#4 @Otto42
5 years ago

When a ticket is closed as not-approved, and the sync runs, then it will mark that version as "old" in the meta, correct? Well, that means it's not "new" anymore. So the uploader will fail this check:
'new' == $this->theme_post->_status[ $this->theme_post->max_version ] )

And create a new ticket. Won't matter that the ticket is re-opened, it will never get to that check because reopening the ticket doesn't make it new again.

Last edited 5 years ago by Otto42 (previous) (diff)

#5 @obenland
5 years ago

r1382 and https://dotorg.trac.wordpress.org/changeset/9983 added the ability to handle ticket reopenings.
Someone would have to add an updated version in the max 15min between ticket reopening and sync script running to achieve that.

Note: See TracTickets for help on using tickets.