WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2378 closed defect (fixed)

Underscores not appearing in SyntaxHighlighter

Reported by: hardeepasrani Owned by: coffee2code
Milestone: Priority: normal
Component: Handbooks Keywords: has-patch commit
Cc:

Description (last modified by SergeyBiryukov)

Just like this: #1928

It's also happening in Handbooks, you can see here live: https://make.wordpress.org/core/handbook/best-practices/coding-standards/php/

Happening on Firefox, and a screenshot is attached which underlines the issue.

Attachments (3)

Handbook.png (49.9 KB) - added by hardeepasrani 2 years ago.
Issue is underlined.
missing-underscore.png (20.6 KB) - added by rinkuyadav999 2 years ago.
meta-2378.patch (660 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (11)

@hardeepasrani
2 years ago

Issue is underlined.

This ticket was mentioned in Slack in #docs by hardeepasrani. View the logs.


2 years ago

#2 @Otto42
2 years ago

I can't reproduce this. Looks correct to me in both Chrome and Firefox on Windows.

Windows 10
Chrome 57.0.2970.0 (Official Build) dev (64-bit)
Firefox 50.1.0

This ticket was mentioned in Slack in #docs by hardeepasrani. View the logs.


2 years ago

#4 @coffee2code
2 years ago

  • Keywords reporter-feedback added

Unable to reproduce as well.

@rinkuyadav999 (original reporter from Slack), if this is still an issue please provide more details: browser, browser version, operating system, etc.

#5 @rinkuyadav999
2 years ago

Hi @coffee2code

yes i still see, underscore does not appear.

Windows 7 ultimate 64 bit
Firefox v 50.1.0 (32-bit)
Works fine in chrome Version 55.0.2883.87 m (64-bit)

When i replace this css:

.syntaxhighlighter table td.code .line {
	padding: 0 1em !important;
}

with this css:

.syntaxhighlighter table td.code .line {
	padding: 0 1em 1px 1em !important;
}

it display underscore.

#6 @SergeyBiryukov
2 years ago

  • Description modified (diff)

#7 @SergeyBiryukov
2 years ago

  • Keywords has-patch commit added; reporter-feedback removed

Reproduced in Firefox on Windows 7. Adding a small bottom padding like in [3853] fixes it.

#8 @coffee2code
2 years ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 4666:

W.org P2 child theme: Add slight padding-bottom to syntax highlighted code container.

Fixes edge case where underscores in the last line of syntax highlighted code get clipped for some people.

Props SergeyBiryukov, rinkuyadav999.
Fixes #2378.

Note: See TracTickets for help on using tickets.