WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2387 closed defect (fixed)

Plugin Directory: <title> tags

Reported by: SergeyBiryukov Owned by: obenland
Milestone: Priority: normal
Component: Plugin Directory Keywords: has-patch commit
Cc:

Description

In #1105, <title> tags for WordPress.org were overhauled.

In the current plugin directory, the format is:

Akismet &mdash; WordPress Plugins

In the new plugin directory, the format doesn't account for those changes, which seems like a regression:

Akismet &#8211; Plugin Directory &mdash; WordPress

Attachments (1)

2387.patch (871 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (7)

#1 follow-up: @obenland
2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Looks like that is fixed? I can't seem to identify a specific commit to change that, but it displays correctly now.
Please feel free to reopen if it changes again

#2 in reply to: ↑ 1 @SergeyBiryukov
2 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to obenland:

Looks like that is fixed? I can't seem to identify a specific commit to change that, but it displays correctly now.

I don't see any changes. The ticket is still valid, exactly as reported.

The current title is:

Akismet &#8211; Plugin Directory &mdash; WordPress

The correct title with the changes from #1105 should be:

Akismet &mdash; WordPress Plugins

#3 @obenland
2 years ago

My apologies, I misread the ticket. I thought it was just about the third title part which I could swear didn't show up for me for some reason.

#4 @obenland
2 years ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from reopened to closed

In 5203:

Plugin Directory: Use a SEO-optimized site name for titles.

See #1105.
Fixes #2387.

@SergeyBiryukov
2 years ago

#5 @SergeyBiryukov
2 years ago

  • Keywords has-patch commit added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Minor nitpicking: #1105 went with &mdash; as a separator, while the current directory uses &#8211;, which is inconsistent with themes:

Akismet &#8211; WordPress Plugins
Twenty Seventeen &mdash; Free WordPress Themes

2387.patch solves that.

#6 @obenland
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 5213:

Plugin Directory: Use emdash as title separator

Props SergeyBiryukov.
Closes #2387.

Note: See TracTickets for help on using tickets.