WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 8 months ago

#2723 closed defect (fixed)

Popular plugins feed doesn't validate

Reported by: iandunn Owned by: iandunn
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: has-patch commit
Cc:

Description

The popular plugins feed (which is fetched by the News dashboard widget in Core) is outputting invalid. Because of that, the News widget isn't showing the plugins.

var_dump( fetch_feed( 'https://wordpress.org/plugins/browse/popular/feed/' ) ):

object(WP_Error)[791]
  public 'errors' => 
    array (size=1)
      'simplepie-error' => 
        array (size=1)
          0 => string 'This XML document is invalid, likely due to invalid characters. XML error: Undeclared entity error at line 11, column 24' (length=120)
  public 'error_data' => 
    array (size=0)
      empty

I'm guessing this broke with the launch of the new directory.

Attachments (1)

2723.patch (653 bytes) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (4)

#1 @iandunn
8 months ago

Possibly related: #624

Related wp:#40416

Last edited 8 months ago by iandunn (previous) (diff)

#2 @SergeyBiryukov
8 months ago

  • Keywords has-patch commit added
  • Milestone set to Plugin Directory v3.0

Caused by the — entity added in [5213].

2723.patch should solve this.

#3 @iandunn
8 months ago

  • Owner set to iandunn
  • Resolution set to fixed
  • Status changed from new to closed

In 5320:

Plugin Directory: Replace — with — in feeds.

— is not a valid entity in an RSS feed.

Fixes #2723
Props SergeyBiryukov

Note: See TracTickets for help on using tickets.