WordPress.org

Making WordPress.org

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#3902 closed defect (fixed)

back to Top link is hidden behind title, when it is targeted

Reported by: pcarvalho Owned by: coffee2code
Milestone: Priority: normal
Component: Developer Hub Keywords:
Cc:

Description

When using the toc to navigate to sections, the titles are applied this:

.toc-heading:target {
    position: initial;
    [...]

which make it cover the "Top ↑" link. By removing or changing it to

position: initial

, the link is now clickable again.

This change seems to be introduced here: https://meta.trac.wordpress.org/ticket/2793

example: https://developer.wordpress.org/reference/classes/wp_query/#status-parameters

Steps to reproduce

  1. click on any entry in the TOP
  2. Try to go back to top by clicking on "Top ↑"

Change History (2)

#1 @coffee2code
11 months ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 7824:

Developer: Prevent handbook section links that link to top from being unclickable.

Props pcarvalho.
Fixes #3902.

#2 @pcarvalho
11 months ago

thanks for the quick fix @coffee2code!

much appreciated!

Note: See TracTickets for help on using tickets.