WordPress.org

Making WordPress.org

Opened 5 months ago

Closed 5 months ago

#5502 closed defect (fixed)

Plugin Directory: Readme Validator thinks valid Readme is invalid

Reported by: Ipstenu Owned by: Otto42
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

https://wordpress.org/plugins/developers/readme-validator/

If you paste in https://wordpress.org/plugins/readme.txt (or use it as the link) it thinks it's wrong and tells you it's missing values that are, in fact, there.

Also tested it with Hello Dolly - https://plugins.svn.wordpress.org/hello-dolly/trunk/readme.txt - and it says that the tested up to field is missing. Which it's not.

Change History (3)

#1 @Ipstenu
5 months ago

  • Summary changed from Plugin Directory: Readme Validator thinks the example Readme is invalid to Plugin Directory: Readme Validator thinks valid Readme is invalid

#2 @Otto42
5 months ago

In my testing, this is not the case.

For the example file, it specifically doesn't like "=== Plugin Name ===" and this is intentional, since we expect authors to change the plugin name line in their readme, so the parser fails for that specifically. It also complains about the Contributors line not having valid ID's in it. Once you make those changes, then it passes.

For Hello Dolly, it doesn't complain about the tested up to line. Instead, it says these:

The Requires PHP field is missing. It should be defined here, or in your main plugin file.
No == Frequently Asked Questions == section was found
No == Changelog == section was found
No == Upgrade Notice == section was found
No == Screenshots == section was found
No donate link was found

All of which are true.

Edit: Just updated my sandbox and can reproduce this, which means that it is a recent change. Probably [10429]. Will examine it.

Last edited 5 months ago by Otto42 (previous) (diff)

#3 @Otto42
5 months ago

  • Owner set to Otto42
  • Resolution set to fixed
  • Status changed from new to closed

In 10430:

Plugin Directory: Readme Parser: Allow data:text/plain streams to pass through parse_readme() also, to allow them to become plain contents before parsing them. Fixes #5502, corrects [10429].

Note: See TracTickets for help on using tickets.