WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 2 years ago

#661 closed enhancement (maybelater)

Add Markdown support to WordCamp.org CPTs

Reported by: jeherve Owned by:
Milestone: Priority: low
Component: WordCamp Site & Plugins Keywords:
Cc:

Description

Jetpack's Markdown module can be used on WordCamp sites, but Markdown is only supported for Posts and Pages by default.

I think it’d be useful to add support for the other Post Types as well, it won't break existing content, but it will provide a consistent experience for authors who already write Posts in Markdown and expect to be able to do the same everywhere else on their WordCamp site.

Attachments (1)

wordcamp-markdown-cpt.diff (5.0 KB) - added by jeherve 5 years ago.
Add Markdown support to WordCamp CPTs

Download all attachments as: .zip

Change History (10)

@jeherve
5 years ago

Add Markdown support to WordCamp CPTs

#1 @jenmylo
5 years ago

We would then also need to provide support and documentation to organizers on working with Markdown in our WC-specific stuff. Is that something the Jetpack team could contribute (documentation for plan.wordcamp.org, and answering support questions on using Markdown if any come in)?

#2 @georgestephanis
5 years ago

I'm not sure how much documentation is really needed, apart from saying "Hey, you can use Markdown" -- if they don't know what Markdown is or don't want to use it, they can continue editing as they always have.

But yeah, if questions come in about how to use it, we do support for all Jetpack modules, Markdown included, and would be happy to answer/troubleshoot any issues that arise, as we already do. :)

#3 @tomauger
5 years ago

  • Cc d3@… added

#4 @kraftbj
4 years ago

  • Cc kraft@… added

We could port https://en.support.wordpress.com/markdown-quick-reference/ into a more WC-friendly place. What's the best way to help pass that over (or is simply a page linking to the en.support guide suitable?

#5 follow-up: @iandunn
4 years ago

I think it'd be much better to just link to it, rather than copying it, and then having to keep it in sync.

I'm not sure we even need any documentation on Plan, though. We don't have any docs specifically for other Jetpack modules. People assume that if the module is activate that it will work, and this ticket just makes that true.

It'd be nice if Jetpack automatically added support to all registered CPTs when the markdown module is active, though. It seems kind of weird to ask every plugin in the world to specifically add support for another plugin, which may not even be installed on most of the servers those plugins run on.

#6 in reply to: ↑ 5 @jeherve
4 years ago

Replying to iandunn:

It'd be nice if Jetpack automatically added support to all registered CPTs when the markdown module is active, though.

The problem is, not every CPT uses the_content, and not every CPT using the_content uses it the same way. Assuming that Markdown should be supported by default can be dangerous, as not all plugin authors would want that to happen, I think. But that's probably not a question for this ticket. :)

#7 @samuelsidler
4 years ago

Given a bunch of text patterns will be built-in to WordPress 4.3, do we really need markdown? :)

#8 @iandunn
4 years ago

The problem is, not every CPT uses the_content, and not every CPT using the_content uses it the same way...

Given a bunch of text patterns will be built-in to WordPress 4.3, do we really need markdown? :)

Both good points :)

#9 @iandunn
2 years ago

  • Priority changed from normal to low
  • Resolution set to maybelater
  • Status changed from new to closed

I'm gonna close this since Core now supports more Markdown-ish patterns, and since this has stagnated for years, but feel free to reopen it if you disagree.

Note: See TracTickets for help on using tickets.