Making WordPress.org

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#7323 closed defect (bug) (invalid)

BUG / Issue with this WordPress support forum

Reported by: peopleinside's profile peopleinside Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Hi, I want report an issue that happen when I need request support using the WordPress.org forum.

This issue happen more then one time in different mounts and caused my replies and post to be lost forever. I need rewrite from zero a long post after this forum has made my post to be lost before was submitted.

There are two different issues. One issue happen if from a PC where I’m logged into my WordPress.org account I start a discussion or I reply to a discussion then I get out of my PC and on my mobile phone I receive an email with a reply from a plugin developer or from you. What I do I open the link to reply from the mobile but I’m not logged into WordPress from the mobile, I log in and I’m able to reply.

Then I go back to my PC where I was logged. I click again on an email link to add info on one or another topic, I was able to write a reply but when I submit the reply the reply is lost because the system ask me to login.

Going back with the browser button never help to save the text not submitted that is lost forever.

The first issue happen because seems I can be logged just from one device, if one device (PC) is logged then, in a second moment, I login from a mobile phone and reply, when I get back to the PC I will see me logged in the forum but when I write a short or a long reply and press submit, the message is lost, not submitted and I see I need log in and write again from zero my reply.

The second issue is that I accidentally clicked a browser button that made the browser change the page while I was writing a reply in the forum. All text loosed. There is no alert in the browser that stop leaving the page if an input text has been made in the forum.

Will be nice if this two issues can be reported and I hope in a fix in the future. Loose text like this reply, that is long, is stressful.

https://wordpress.org/support/topic/bug-issue-with-this-wordpress-support-forum/

Change History (7)

#1 @Otto42
7 months ago

Logins are browser specific. Logging in on one device will not cause you to be logged out on another.

#2 @peopleinside
7 months ago

Logins are browser specific. Logging in on one device will not cause you to be logged out on another.

Are you sure about that?
Consider that before made this BUG report I loosed my post and replies in WordPress forum in different days and different months.

As I use the PC and mobile discover that be logged by the PC and then after that log in in mobile made me unable to post replies from the PC anymore if I never log in anymore in WordPress account. The bad thing is that WordPress forum show me logged in the PC, let me post the reply and when I submit the reply is not registered and a link to login is presented. After that I need rewrite the reply from zero.

This made me loose messages more then one time in a year.
This happen also today.

I partecipate to the WordPress community for a long from my PC then I was to lucnh far from the PC. Received an email with a reply in the forum, logged from mobile and made a reply.

After that when in the afternoon I return ot the PC I clicked again mail link to open discussion an add a reply, the form to write a reply was present but one submitted a link to login was showed and my message get lost.

Also no alert is showed if a input text in the forum has been made without be submitted and accidentally browser try to change page because maybe a keyboard or a button on the browser has been pressed for error like the back button.

I hope you can fix the WordPress community to avoid this two issues that made me loose replies that I write and I was not able to send, during the years.

#3 follow-up: @peopleinside
7 months ago

If the issue is not caused by the login from another device maybe my PC session expired.
How much long the login session are kept in the PC? Days?

In any cause the issue is present: what happen is the forum is opened by an email link, let me post the reply and when I submit the message are not saved and the system show me the link to login.

If this issue cannot be fixed, a way to go back with the browser button and find the text that was not submitted, should be implemented.

More then one time I loose complex and long reply to the WordPress forum because of this issue so it's not a new issue to me. I use Firefox but I can use WordPress forum for days from the PC. I don't know what is the cause of the issue but I know just today I logged from a mobile for update replies I made by the PC. Once i come back to the Pc and post update also from here, my message was not submitted, my account logged aut and a link to login was showed. No way to recover the text not submitted.
This should be not happen.

Even if user type a text and the browser try to change a page for a wrong back button pressed... there is no check no alert to prevent the page leave loosing user input.

#4 in reply to: ↑ 3 @Otto42
7 months ago

Replying to peopleinside:

Are you sure about that?

Yes. For assorted reasons, sessions like they are used in WordPress, are not used in wordpress.org. The login information is entirely cookie based and saved in your browser cookies. This is the way WordPress used to do it before the introduction of sessions in the user meta table.

Replying to peopleinside:

If the issue is not caused by the login from another device maybe my PC session expired.
How much long the login session are kept in the PC? Days?

Two days if you do not check the remember me checkbox, 14 days if you do check it.

#5 @peopleinside
7 months ago

@Otto42 thanks for the reply.
I always use the remember me check box.

I don't know if today the session expired in the exact time where the forum was opened with the field to write a reply, my reply was written then, pressing send made me loose everything. Is not the first time this issue occurs with WordPress.org forum.

This is why I opened this issue. I loosed long reply. I should start to remember to save the text before send as "the forum seems to be indefinable". Even press the back button once the message has not been sent and the login link is showed, never help to get back the text.

Now I leave this to you, you can decide to leave all as is or made consider a fix.
I reported the issue as this happened more then one time.

It's not my browser issue as I stay logged in WordPress forum for days.
Usually I don't get this issue when I use forums, just WordPress.org

Maybe the issue can be that when the forum is opened and a reply has been written and the forum show you are logged in then you press send to send the reply you made.. the reply is lost. This should not happen because this issue can happen every 14 days or two days.

I let this report to you. Let me know if you need more help or info from me.
I consider this bug may be closed by you without a fix, what I can do is just report this issue and I have already done today after the second or the third time I loose a big long reply written on the forum.

#6 @Otto42
7 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Unfortunately, without more information there is a very little we can do to fix this. It does not sound like an issue with the site, it sounds like an issue with your browsers, and possibly any privacy extensions that you may have which either block or remove cookies.

If you find a solid way to reproduce the issue, then feel free to reopen or post information here, but if we can't make it happen, then we cannot do anything to fix it.

Last edited 7 months ago by Otto42 (previous) (diff)

#7 @peopleinside
7 months ago

I'm deluded by this reply and ticket but is what I can expect.
I can understood that if you are unable to reproduce, can be not possibile made a fix but, not all of what I wrote is impossibile or hard to reproduce.

My ticket and my report is about your forum software used for give support at WordPress.org reporting to you I'm loosing many times replies I made. Why this happen?

It's easy to reproduce part of what I'm reporting.
You just need to open a topic or a reply template in the forum and made some input in the text editor, now try to press the back button of the browser for example. You need have visited a different page before reach the forum input field. When the browser try to redirect you to another page, there is no forum check to avoid the input text inserted in the forum and not yet send, is lost.

Usually forums and form alert with a message box if input text has been made and is not saved or send. The message box allow you to stay in the page to avoid text loosing.

Not only this is not present but when the browser change the page, if you try to get again in the form where your text was written without be saved or sent, the form will be erased from all text.

If you will avoid this, maybe the issue I reported about the forum that let me write a reply but when I press send a login link is showed and all text loosed, can be restored.

I suppose my report is just a single report that has no importance. You need maybe more users that report the same issue I'm reporting for considering a fix.

I think is bad when a input field let user type input without have any measure to avoid text loosing before this text are submitted then saved in the database.

I note that the ticket is closed without a solution.

https://i.postimg.cc/s2rL38KX/issue.gif

What is showed above is just a showing of missed checks to avoid text loosing.
The first issue that I reported and that is not replicable to you is that I experienced, more then one time, that opening a mail topic link show me the forum reply input where I typed a reply and once press the send button the input field was hidden and a log in to reply link was showed.

In this case will be useful be able to go back with the browser button and still see the input text that has been not submitted because after pressing the submit button the active session was no more valid.

Last edited 7 months ago by peopleinside (previous) (diff)
Note: See TracTickets for help on using tickets.