Making WordPress.org

Opened 6 weeks ago

Closed 5 weeks ago

#7595 closed defect (bug) (duplicate)

Edited reviews do not show as recent

Reported by: dd32's profile dd32 Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords: 2nd-opinion
Cc:

Description

When you edit a review, the review date remains the same as when it was made.

For example, if I update a review I made 7 years ago, it'll still show as being made 7 years ago and show after a review made 2 years ago.

This is problematic (to me), as it means that review from long-time users of a plugin/theme isn't shown to others.

The other side of this however, is that it would mean sock-puppet reviewers would then have a reason to keep editing the review, to ensure that their good reviews show above others. Perhaps editing after a while should only be possible if the rating changes.

Notably; When a review is updated, the date stored with the rating is updated to the edit time, which would likely affect #6851

Change History (4)

#1 @tobifjellner
6 weeks ago

Alternative approach, which would reuse more of our settings and workflows in other parts of the forums:

Lock reviews for editing by subscribers in the same way as for posts and comments in other forums, but when a new review is made, the previous one goes into an "outdated" state, where it will be marked as "outdated", possibly hidden from public, and (obviously) the rating won't be included in the average rating.

Last edited 6 weeks ago by tobifjellner (previous) (diff)

This ticket was mentioned in Slack in #forums by courtneyengle. View the logs.


6 weeks ago

#3 @dd32
6 weeks ago

but when a new review is made, the previous one goes into an "outdated" state

This was also something that I was going to suggest, but I wasn't sure if it was the "right" option or not.

The only question I have, is should the "outdated" review still be visible? Or should it be hidden? The outdated review shouldn't affect the plugin rating at all.

Is there any benefit to showing the outdated review to end-users? It's only really moderators who need that context.

#4 @dd32
5 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6094.

Note: See TracTickets for help on using tickets.