Making WordPress.org

Opened 8 weeks ago

Last modified 7 weeks ago

#7612 reopened defect (bug)

Closed reviews should not have a reply message box

Reported by: jcastaneda's profile jcastaneda Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

This was reported by a participant of the forums here: https://wordpress.org/support/topic/how-to-contact-moderator-2/

The topic was a review, but the message does display on regular posts as well for what may be all role types. The message reads:

This topic is marked as closed to new replies, however your posting capabilities still allow you to reply.

The message is somewhat accurate because the review is closed for new replies but participants should not be able to reply, if they do make an attempt to there is a secondary message that shows up stating:

Error: Topic is closed.

The expected behavior

There should be no reply message box displayed when a topic has been closed

The actual behavior

A replay message box is shown for all roles.

Change History (3)

#1 @Otto42
8 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed

You are a moderator on the forums. You will see that on all closed topics, because you are a moderator. Moderators can reply to closed topics.

#2 @Otto42
8 weeks ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Ahh, I understand the issue.

That user should not be seeing that at all, because he is not a moderator.

#3 @dd32
7 weeks ago

  • Summary changed from Closed topic should not have a reply message box to Closed reviews should not have a reply message box

bbp_current_user_can_access_create_reply_form() says that yes, the user can access the create reply form.

This is because the user can edit the topic - as they can edit the review.

bbPress doesn't seem to handle the case of editing is permitted, but new replies are not. This probably needs filing upstream, although it's a super-edge case that WordPress.org allows somewhat awkwardly.

This is probably best handled via removing edit-old-review functionality via #7064 or through allowing plugin authors to respond anytime via #3505

Note: See TracTickets for help on using tickets.