WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 3 years ago

#961 closed defect (fixed)

Plugin Stats major version grouping is too greedy

Reported by: dd32 Owned by:
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

At present if the version graph is going to show >6 releases or so, it starts grouping things into an older releases section.

the problem is, that for some plugins, it ends up grouping the active version too, eg:
https://wordpress.org/plugins/wp-all-import/stats/

I suspect this is mostly caused by custom plugin versions getting into our stats - we should probably remove any version from the graph which are higher than the current stable.

Change History (6)

This ticket was mentioned in Slack in #meta by sam. View the logs.


4 years ago

#2 @ocean90
4 years ago

Related: #1147

#3 follow-up: @Ipstenu
3 years ago

we should probably remove any version from the graph which are higher than the current stable.

Yes, let's do that.

#4 in reply to: ↑ 3 @dd32
3 years ago

  • Milestone set to Plugin Directory v3.0

Replying to Ipstenu:

we should probably remove any version from the graph which are higher than the current stable.

Yes, let's do that.

As a FYI; This should be fixed in the new directory. The code is here:
https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/api/routes/class-internal-stats.php#L99

It looks like there may be a bug still though, as https://wordpress.org/plugins-wp/wp-all-import/admin/ isn't showing a 3.4 version (the latest stable)

#5 follow-up: @Ipstenu
3 years ago

It shows it now, Dion! Magic! (Or syncing...)

#6 in reply to: ↑ 5 @dd32
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Replying to Ipstenu:

It shows it now, Dion! Magic! (Or syncing...)

It shows now, because it turned out 3.4.0 had been released between the last stat sync, and when i looked at it. Acceptable for it to be not shown in that case I feel! (It updates the stats daily).

Note: See TracTickets for help on using tickets.