WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 8 months ago

#2664 closed defect (fixed)

Plugin Directory: Re-add the link to plugin's SVN repository

Reported by: shazahm1@… Owned by:
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: has-patch commit
Cc:

Description

The repository URL is no longer on the page on the new directory page. Just yesterday it was under the new "Contributors & Developers" section

Example:

http://plugins.svn.wordpress.org/splugin-slug

Attachments (4)

Interested in Development Links.png (13.8 KB) - added by lukecavanagh 9 months ago.
Interested in Development links
Interested in Development Example.png (15.4 KB) - added by lukecavanagh 8 months ago.
Interested in Development Trac and SVN Links
2664.patch (3.0 KB) - added by SergeyBiryukov 8 months ago.
2664.PNG (11.5 KB) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (31)

#1 @Otto42
9 months ago

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug, it is intentional.

See [5218], #2629, and #1824.

#2 @Ipstenu
9 months ago

  • Milestone set to Plugin Directory v3.0
  • Type changed from enhancement to defect

This should be restored, as it's useful when you don't need to see revisions etc and just want to check what you did wrong with your readme and tags.

#3 @shazahm1@…
9 months ago

It was very useful for devs ... I can't imagine I'm the only one. Copy the link, use Tortoise to checkout the repository.

Or,

is there a new preferred way devs should locate the URL for plugins?

Right now, the only way I could figure it out was to check the properties of a plugin I had checked out, copy it and change the slug.

Why make it harder for devs to checkout? I know I must be missing something simple, right?

#4 @SergeyBiryukov
9 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

The link to the plugin's SVN repository could be moved to admin section so it's only displayed to plugin developers, but I don't see a reason to remove it completely.

#5 @shazahm1@…
9 months ago

Yes, it could be moved to the admin section, but... I often checkout plugins for which I am not a contributor to so I would not have access to the admin page.

#6 @lukecavanagh
9 months ago

Please restore the link to plugins.svn and not plugins.trac, as mentioned before plugins.trac is slower to load and plugins.svn is more relevant. This relates to #2365 as well.

Last edited 9 months ago by lukecavanagh (previous) (diff)

#7 follow-ups: @Otto42
9 months ago

I think that if it is not useful information for end-users, then it should not be on the front page. On the admin page is arguable.

Given that the plugin SVN url is always the same: plugins.svn.wordpress.org/$plugin-slug, then any developer should pretty much know it without having to have a link explicitly given to them.

Additionally, when a plugin is created, the SVN url is emailed to the author, along with all sorts of links and instructions.

So, discoverability of the SVN link is not really all that difficult. What problems would be solved by adding it to the admin section?

Last edited 9 months ago by Otto42 (previous) (diff)

#8 @lukecavanagh
9 months ago

@Otto42

Changing from plugins.trac over plugins.svn makes it slower to load on those links. Because end-user still do look at svn to browse plugin code, I still do this if a plugin might have an issue, instead of looking through the code after downloading the zip and extracting in an IDE. Making things harder to get to is not improving the default experience.

Last edited 9 months ago by lukecavanagh (previous) (diff)

#9 in reply to: ↑ 7 ; follow-up: @SergeyBiryukov
9 months ago

Replying to Otto42:

Additionally, when a plugin is created, the slug is emailed to the author, along with all sorts of links and instructions.

So, discoverability of the SVN link is not really all that difficult. What problems would be solved by adding it to the admin section?

Emails can easily be lost or missed, and not every new developer might be familiar enough with the system to figure it out on their own. If we could make the link a bit more discoverable for developers and the whole UX a bit more friendly, I don't see why we shouldn't.

#10 @Otto42
9 months ago

Because end-user still do look at svn to browse plugin code

Really? I know a lot of end-users, and not one of them knows a thing about code.

Don't get me wrong, it's certainly useful for other programmers and developers, but end-users? End-users generally don't know what FTP is, or how to edit files on their hosting systems. End-users install WordPress using one-click installers, and install plugins through their wp-admin screens. End-users don't generally look at code or install ZIP files of plugins. Power users do, sure. Not arguing that.

But I think it is a legitimate argument to make that the SVN link is not useful to the vast majority of users, and having it around adds confusion. Even the old directory limited it to the Developers tab.

Heck even developers have confusion surrounding it. Every single week, we have a case where we approve a plugin for the directory, and the plugin author emails us back saying "I clicked this SVN link you gave me, but the site is broken and there's no upload button there". I've answered that question hundreds of times. I have a stock response for it.

#11 @shazahm1@…
9 months ago

're; I think that if it is not useful information for end-users,'

Ok, then by that logic then why is there a "INTERESTED IN DEVELOPMENT?" section at all on the front page. The reasons must be devs, right? What is the issue in providing devs an easy copy/paste link for the repo?

#12 @lukecavanagh
9 months ago

@Otto42

Developers are end-users in WordPress, saying that end-users do not know code or want to look in code is a pretty broad generalisation. Also end-users do install plugins using a zip upload, since those premium purchased plugins are purchased and then installed by zip upload. Also since those plugins are not on the WP repo. End-users do know how to use FTP, they might use know how to use FTP when they first start using WordPress, but they will learn how to use it.

Last edited 9 months ago by lukecavanagh (previous) (diff)

#13 @Otto42
9 months ago

But they are not the only end-users, is what I'm getting at. It makes sense for there to be a separation where we display things that the majority care about right up front, and lesser used items in a somewhat more hidden way.

Not opposed to putting additional links and such in the admin areas.

#14 @lukecavanagh
9 months ago

@Otto42

But the admin areas would be hidden by default though. So do not remove or hide things by default or make things harder to find by default on load

#15 @Otto42
9 months ago

I'm already following this ticket, you don't have to keep @'ing me, thanks.

#16 @shazahm1@…
9 months ago

Not opposed to putting additional links and such in the admin areas

But what about users who wish to checkout the code which do not have access to the admin? Would a user interested in development not want the URL to be able to actually checkout the project so they can contribute? Surely the SVN URL is more useful that then RSS feed URL? How about removing the RSS URL and replace it the the SVN URL. I mean, we're talking about content that on the front page that is already hidden by default. For actual users having URL will not make a different because they will never see it, right?

#17 in reply to: ↑ 9 @Otto42
9 months ago

Replying to SergeyBiryukov:

If we could make the link a bit more discoverable for developers and the whole UX a bit more friendly, I don't see why we shouldn't.

I agree with this, just not with reverting it back to having that list of five links there. Suggestions for how to better display this information would be welcome.

@lukecavanagh
9 months ago

Interested in Development links

#18 @Ipstenu
9 months ago

We could be as simple as this:

Browse the code on [trac] or [svn], or subscribe to the [development log] by [email].

It's more contextual.

I think the 'best' place would be wherever we figure out to put the previous versions (see #2365 ) actually.

ETA: I removed the milestone because this is not mission critical to call the rollout complete and ready for iteration. It should be fixed, I agree, but it doesn't have to be right this very second.

Last edited 9 months ago by Ipstenu (previous) (diff)

#19 @Otto42
9 months ago

  • Milestone changed from Plugin Directory v3.0 to Plugin Directory v3 - Future

#20 @SergeyBiryukov
9 months ago

  • Summary changed from SVN repository URL was respiratory was remove from new design. to Plugin Directory: Re-add the link to plugin's SVN repository

@lukecavanagh
8 months ago

Interested in Development Trac and SVN Links

#21 in reply to: ↑ 7 @johnbillion
8 months ago

I just went looking for the SVN URL for a plugin of mine which I want to update. Removing this sort of meta information from the plugin admin screen does not make sense.

Replying to Otto42:

Given that the plugin SVN url is always the same: plugins.svn.wordpress.org/$plugin-slug, then any developer should pretty much know it without having to have a link explicitly given to them.

Who -- outside of the tiny circle of meta contributors and plugin team members -- would possibly be expected to know this?

Additionally, when a plugin is created, the SVN url is emailed to the author, along with all sorts of links and instructions.

What about two years later, or when you've moved machines? Who would think to hunt for that email in their inbox?

This ticket was mentioned in Slack in #meta by sergey. View the logs.


8 months ago

#23 @Otto42
8 months ago

Who -- outside of the tiny circle of meta contributors and plugin team members -- would possibly be expected to know this?

You know there are over 20k plugin authors, right? It's not like it's a tiny group of people.

@SergeyBiryukov
8 months ago

#24 @SergeyBiryukov
8 months ago

  • Keywords has-patch commit added

In 2664.patch:

  • Add "check out the SVN repository" link to "Interested in development?" section for logged in users.
  • Keep the section for logged out users as is.
  • Add missing text domain, while we're at it.

Screenshot: 2664.PNG.

This ticket was mentioned in Slack in #meta by lukecavanagh. View the logs.


8 months ago

#26 @tellyworth
8 months ago

In 5325:

Plugin directory: include a SVN link in the Interested In Development section. Props @SergeyBiryukov

See #2664

#27 @SergeyBiryukov
8 months ago

  • Milestone changed from Plugin Directory v3 - Future to Plugin Directory v3.0
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.