WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 4 months ago

Last modified 4 months ago

#4400 closed defect (fixed)

Monaco font on the handbook on Chromium doesn't show underscores at 100% size

Reported by: santilinwp Owned by: coffee2code
Milestone: Priority: normal
Component: Handbooks Keywords:
Cc:

Description

When viewing the following page on chromium:

https://make.wordpress.org/core/handbook/php-coding-standards-draft-proposal/#naming-conventions

some_name and WP_HTTP are shown without the underscore. If I make the font bigger to 110%, then the underscores appear.

I've attached a snapshot.

Attachments (1)

missing-underscores.jpg (38.5 KB) - added by SergeyBiryukov 7 months ago.
Screenshot from https://core.trac.wordpress.org/ticket/47000

Download all attachments as: .zip

Change History (5)

#1 @SergeyBiryukov
5 months ago

#4526 was marked as a duplicate.

#3 @coffee2code
4 months ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 9056:

Breathe: Add slight padding-bottom to SyntaxHighlighter code container.

Fixes edge case where underscores in the last line of syntax highlighted code get clipped for some browers or browser configs.

Props santilinwp, SergeyBiryukov, coffee2code.
See [4666].
Fixes #4400.

#4 @coffee2code
4 months ago

Though I can't reproduce the issue, I've implemented the same fix as for this identical issue but on a different site. Let me know if the padding I've used is insufficient.

Note: See TracTickets for help on using tickets.