Making WordPress.org

Opened 15 months ago

Last modified 6 weeks ago

#6834 reopened enhancement

Support Forums: Require a reason when flagging a user

Reported by: clorith's profile Clorith Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Currently, when flagging a user, it's a single-click action, and relies on the flagger adding a user-note, and the user them selves are left without much information.

By improving the flagging procedure, we can request a reason for the flagging, and automatically include this in the user notes.

In addition, we can improve the user communication by allowing them to see not only that their account is flagged, but also why they are flagged, and set expectations accordingly.

The reason should have some predefined reasons to choose from, which are all based off our guidelines, and allows us to curate the user-facing messages to reduce friction, but must also allow for manual inputs for edge case handling.

This information would be visible to the user on their forums profile, and by having an area dedicated to flagged user information there, we can also tie in #5715 / #5881 to have the ability to flag/unflag a user from the profile as well.

Attachments (2)

6834-flagging.JPG (66.4 KB) - added by Clorith 15 months ago.
Suggested concept: Flagging user form
6834-profile.JPG (86.4 KB) - added by Clorith 15 months ago.
Suggested concept: Profile view for end user

Download all attachments as: .zip

Change History (24)

@Clorith
15 months ago

Suggested concept: Flagging user form

@Clorith
15 months ago

Suggested concept: Profile view for end user

#1 @sterndata
15 months ago

Are you suggesting users be able to see our user notes? I strongly disagree -- at least for the ones prior to when this happens. The notes were written with the common understanding that they are visible only to Moderators and above.

#2 @Otto42
15 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Absolutely not. The entire system of commenting on users will never be available to them. That would destroy the moderation system.

#3 @Clorith
15 months ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

No, users would see the a highly specific reason for why they are flagged, which should always (with exceptions) tie into a guideline violation.

The only relation this has to user notes is that we currently automatically add a note that says who flagged a user, that automated user note would also include the reason you choose.

The intent and purpose is to make a user aware of why their account has been acted on, in a reliable and direct manner, which has both information about what is going on, and what to expect, helping to remove uncertainty and improving the user experience all over.

User notes in general are still tied to the moderate capability as it always has been, as there's clearly been a misunderstanding, I am re-opening the ticket :)

#4 @fierevere
15 months ago

It would be somewhat good to have this optional

We are often setting a flag to see what user is up to, with note "spammer?" or so...
it is bad idea to expose this to user at all, even the fact that the user is modwatched. But for some cases of "long term" modwatch it would be good to post some visible note to user besides @-mention notification which is often missed.

#5 @Otto42
15 months ago

Still a -1 from me.

A user should not know they're flagged by moderators, at all. If they do, that leads to more misunderstandings and more problems rather than less.

#6 @Clorith
15 months ago

The user will know something is up when all their posts show the notice that their posts are pending manual review, the intent behind this approach is to reduce friction, and remove uncertainty from a users perspective.

The moderation guidelines also state that we should not be flagging someone without reason (although we add those as user notes per todays methods), and if we are not comfortable with the flagged user knowing that reason, are we then not potentially prematurely judging them? If it's so obscure that we can't tell if it's good or bad, we should err on the side of good, and can instead check in on them without "negatively impacting" their standings. (let's not forget, the user is more likely to joion #forums on Slack about their posts if they don't know what's going on, and then you not only have to explain your self, but you have to explain your self in public)

Note that the flagged status carries outside the forums as well, although only visually at this time, these are still things we need to be mindful of.

#7 @mrfoxtalbot
15 months ago

I like the idea.

The main scenario where I see these notes being useful is when we leave a reply in a thread, and then archive the reply (sometimes alongside the entire thread). In these cases, we are relying on the user receiving (and seeing) the email to understand that a) they violated a guideline and b) that (maybe) they have been flagged.

Very often (and this happened to me once), they will not receive this email and instead all they will see is that their comment/thread got removed and they are now flagged.

Changing this process from “disposable replies” to “persistent private notes” feels like a good move towards clarity. In fact, if we included some information alongside the note linking to the guideline that was infringed and explaining what steps need to be taken for the flag to be lifted, we could reduce the number of users coming into the #forums channel asking what happened and how they can fix it.

@Clorith, I recall you mentioned that these notes would display who added them only to other moderators. Are you still planning do this? If so, users not being able to see what specific moderator added the note would contribute towards anonymity and prevent personal attacks.

A user should not know they’re flagged by moderators, at all.

@Otto42, I am not sure I agree (or maybe I do not fully understand). They way I see it, if a user violates a guideline because they are unaware of it, pointing them in the right direction would reduce misunderstandings and encourage them to continue contributing.

On the other hand, I see what @fierevere says in terms of not wanting to leave notes in some scenarios. What would be some cases where leaving notes would be counterproductive?

This is promising, thanks again @Clorith!

#8 @fierevere
15 months ago

normal, active users who violated something and are flagged for modwatch are the "top of the iceberg", there are much more users who are precautionary flagged

  • suspected spammers
  • posting test messages
  • people acted weird, flagged just to see their next post(s) and then unflag if there will be nothing wrong.

and some other cases, where it is better not to expose the fact that the user is modwatched , especially spammers
Also when someone need to calm down (We're often using it in Rosetta, where the community is smaller and posts stream is under better control) sometimes we dont need to post any further notes, where user already had enough (trolling, being toxic, provocative, etc)

my opinion is - optional user visible reason, not mandratory.
It is bad idea to expose the reason and the fact that someone is flagged, may/will provoke conflicts and unnecessary grudge from users who are on short term modwatch.

Last edited 15 months ago by fierevere (previous) (diff)

#9 @thelmachido
15 months ago

I agree it would be great for folks to know the reason why they have been flagged.

Sometimes people come into forums without reading the guidelines, in these cases, they will write or do something that is against the guidelines without even realizing it.

It's fair to let people know what they have done wrong to give them a chance to do better in the future.

This ticket was mentioned in Slack in #forums by clorith. View the logs.


15 months ago

#11 @cristiano.zanca
15 months ago

There could be two kind of notes about the flagging reason:

  • one visible only by the user (and the flag author should be anonymous)
  • one visible for all moderators

Let the person know why he is flagged should help to improve his activity in the forum, if we talk about a troll that note should help him to troll more, that's the negative effect

Keep the author note anonymous help the situation to avoid becoming personal

Last edited 15 months ago by cristiano.zanca (previous) (diff)

#12 @Ipstenu
15 months ago

I say this constantly: Asking the volunteer mods to do MORE work results in FEWER mods and MORE mistakes.

Also I want to caution: TELLING someone they got mod-looked for calling people names rarely, if ever, works out well. Seriously few people in the history of ever have taken that well. It's like how asking someone to calm down never works.

I would recommend a different kind of user-note or a form that lets people:

  1. Flag a user _or ban them_ as a dropdown
  2. Pick a general option of WHY flagged (bad language/spammy links/dogpiling on a review/etc) from a dropdown (if OTHER, then it's free form)
  3. Write in a detailed Mod note as to why. Include the stuff like the history, exactly what was said and to whom, etc. This may require some NON PUBLIC info (like IPs and emails) so for privacy protection, it might be different.

That would then email a sanitized version of the situation and now we don't have to worry about mods being followed home. No need to reply in public. Just:

Your reply/post [subject of thread] was removed for [reason from option 2] and your account has been flagged for moderation.

This means [explain what modlook means].

If you have questions/concerns please come to the #forums channel in slack...

The original content of your comment is included below:
[original comment]

#13 @mrfoxtalbot
13 months ago

I like the idea of automating things as much as possible as @Ipstenu explained. If we point to the specific guideline that was infringed, that should provide enough context to help that user avoid making the same mistake again (and hopefully read the rest of the guideline while they are at it).

I also want to highlight that @Clorith's propsal has a second and in my opinion, very important part:

This information would be visible to the user on their forums profile

This is essential as emails tend to get lost in space (or people overlook them, we've always been there).

I would add a suggestion: let's include a message in the "Your comment has been held for moderation" banner telling users that they can find more info about their modwatch status in their profile page.

This ticket was mentioned in Slack in #forums by mrfoxtalbot. View the logs.


13 months ago

#15 @mrfoxtalbot
13 months ago

There are two other tickets that are directly related to this one and we should take into account:

This ticket was mentioned in Slack in #forums by mrfoxtalbot. View the logs.


13 months ago

#17 @mrfoxtalbot
13 months ago

Once start working on this one, it would be a good idea to take into account Forums: The "report button" and related functionality are not available on closed topics and fix that too.

This ticket was mentioned in Slack in #forums by clorith. View the logs.


12 months ago

#19 @jordesign
10 months ago

I just wanted to chime in to say I can see great value in this proposal - and would love to know what is needed to try and push it forward!

In reading through the thread I see the concerns regarding:

  • Additional work for moderators
  • Situations where adding a reason isn't needed (as it is a 'soft' flag, over-communicates to a spammer, or other cases).

I wonder if something like this would work.

Moderator experience

Moderator who is flagging a user has:

  • optional dropdown to select reason
  • Free text field which adds a private user note (as is manually done atm).

User experience

  • As proposed in #5263 updated messaging to users with flagged posts who also have a 'reason' selected. could include a note/link to check their profile.
  • Profile includes the selected 'reason' - along with a predefined further details about the reason. Could also include next steps for rehabilitation.

Would something like that work?

This ticket was mentioned in Slack in #forums by mrfoxtalbot. View the logs.


8 months ago

#21 @jordesign
5 months ago

I've been thinking about this a little further - and with the new Guidelines in place (https://wordpress.org/support/guidelines/) I think we can come up with a list of the 'Reasons' to be selected from when flagging a user.

As a starting point I would propose:

  • Admin asks
  • Offering to pay for help (repeatedly)
  • Spam
  • Posting Dupes
  • Attack Reviews / extortion
  • Abusing the 'Report Topic'
  • Posting private information or correspondence
  • Abuse/Harrasment/Threats

What do folks think? It's possible some of those can be combined (or others need to be added).

Once that list is confirmed - a next step would be to consider what steps a user needs to take to be un-blocked for the specific reason.

This ticket was mentioned in Slack in #forums by jordesign. View the logs.


6 weeks ago

Note: See TracTickets for help on using tickets.