WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 5 months ago

#2109 closed defect (fixed)

Forums: Incorrect data in Forum Info

Reported by: SergeyBiryukov Owned by: dd32
Milestone: Q1 Priority: normal
Component: Support Forums Keywords: has-patch
Cc:

Description

Might be a duplicate of #1971 or #2043 or a known caching issue, but the sidebar info on https://wordpress.org/support/forum/plugins-and-hacks/ looks wrong:

  • 836,866 topics (+ -541 hidden) (note the negative value)
  • Last activity: 4 months, 1 week ago (the last activity was 2 minutes ago)

See the screenshot.

Attachments (3)

meta-2109.PNG (63.3 KB) - added by SergeyBiryukov 3 years ago.
forum-count.png (35.7 KB) - added by ccprog 3 years ago.
Even stranger numbers for Hacks subforum - note the forum has only two accessable pages
2109.patch (955 bytes) - added by Clorith 15 months ago.

Download all attachments as: .zip

Change History (12)

#1 @ocean90
3 years ago

#2163 was marked as a duplicate.

@ccprog
3 years ago

Even stranger numbers for Hacks subforum - note the forum has only two accessable pages

This ticket was mentioned in Slack in #bbpress by netweb. View the logs.


2 years ago

This ticket was mentioned in Slack in #bbpress by thebrandonallen. View the logs.


2 years ago

This ticket was mentioned in Slack in #forums by sergey. View the logs.


2 years ago

This ticket was mentioned in Slack in #forums by clorith. View the logs.


15 months ago

#6 @Clorith
15 months ago

This information in the sidebar isn't really all that useful and provides no real insight for users.

We should just remove them.

@Clorith
15 months ago

#7 @Clorith
15 months ago

  • Keywords has-patch added

2109.patch comments out the section for freshness from the overall forum listing of topics, like we've done with other non-critical data.

#8 @tellyworth
5 months ago

  • Milestone set to Q1

#9 @dd32
5 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 8058:

Forums: Remove the 'Forum Info' sidebar section.

This was previously mostly commented out, but was still displaying the 'Last Activity' which was often out of date due to caching.

Props Clorith for original patch, dd32.
Fixes #2109.

Note: See TracTickets for help on using tickets.