WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 3 years ago

Last modified 23 months ago

#226 closed defect (fixed)

Encoding issues for plugin names on profiles.wordpress.org

Reported by: kovshenin Owned by:
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description

Looks like there are some encoding/charset issues on profiles: http://cl.ly/image/0Z1e0r043w0x (titles should be in Russian and are displayed fine on the rest of WordPress.org)

Change History (13)

#1 @samuelsidler
6 years ago

Is this a *new* encoding issue? Or one you've just noticed?

If it's not new, I'm going to say we punt on it for now as there's a ton of encoding issues, all semi-related and all pending (first) a hyperdb upgrade. Then we can drill down on more specific ones.

If it's new... well... that's unfortunate.

#2 @kovshenin
6 years ago

  • Cc kovshenin@… added

I don't think it's new.

#3 @versusbassz
6 years ago

  • Cc versusbassz added

#4 @SergeyBiryukov
6 years ago

Previously: #wp21035. Related: #23.

nacin's comment from #wp21035:

The problem is different database encodings — some utf8, some Latin-1. This bites us repeatedly but debugging character encoding issues is still not my strong suit, so we are stuck with a number of issues.

#5 @SergeyBiryukov
5 years ago

#655 was marked as a duplicate.

This ticket was mentioned in Slack in #meta by sergeybiryukov. View the logs.


4 years ago

#9 in reply to: ↑ 7 ; follow-up: @coffee2code
4 years ago

  • Summary changed from Encoding issues on profiles.wordpress.org to Encoding issues for plugin names on profiles.wordpress.org

Replying to ocean90:

See also https://profiles.wordpress.org/sergejmueller or https://profiles.wordpress.org/danielhuesken/. Looks fine on wordpress.org/*.

Fixed the quoted issue in [10829-dotorg] as part of #1208.

I changed the name of this ticket to reflect the specific issue about character encoding of plugin names so as not to be an umbrella ticket for all profiles-related character issues. Generally, character issues for each different section of a profile needs a different fix so they should all get their own tickets.

As of this moment, this ticket is the only open character encoding problem I'm aware of for profiles.

#10 in reply to: ↑ 9 @SergeyBiryukov
4 years ago

Replying to coffee2code:

As of this moment, this ticket is the only open character encoding problem I'm aware of for profiles.

Could you also take a look at #117 and #354?

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


3 years ago

#12 @coffee2code
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [12634-dotorg]:
Fix character encoding issue for plugin names containing multibyte characters.

This ticket was mentioned in Slack in #meta by sergey. View the logs.


23 months ago

Note: See TracTickets for help on using tickets.