Making WordPress.org

Opened 3 years ago

Closed 20 months ago

Last modified 20 months ago

#5634 closed enhancement (fixed)

Introduce a 'needs-testing-info' Workflow keyword

Reported by: davidbaumwald's profile davidbaumwald Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: Priority: normal
Component: Trac Keywords: needs-copy-review
Cc:

Description

During the course of WP 5.6 and 5.7, a new custom workflow keyword has been used to request a more documented, patch validation procedure. In the same vein as #4609, this was discussed during Dev Chat on 2/24/21, and there was some agreement on including this in the official list.

As for a definition for needs-testing-info, it could start with...
"Contributors have requested a more detailed testing procedure to validate patch efficacy."

Flagging for a copy review to improve the definition.

Change History (8)

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


3 years ago

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


3 years ago

#3 @hellofromTonya
3 years ago

During 5.6 and 5.7, used needs-testing-info to request needed information for contributors to do manual testing.

Questions asked when applying the keyword:

  • What are the steps to reproduce? (i.e. for defects)
  • What are the steps to test?
  • Are there any testing dependencies, such as a plugin or script?
  • What is the expected behavior after applying the patch?

The answers to these questions help testers whether doing manual testing or creating unit tests.

Why this keyword?

  • Tickets are tagged with needs-testing. However, this keyword does not indicate if the ticket is in a state to be tested. Adding needs-testing-info alerts triage, ticket owner, maintainers, and testing team that this ticket needs more information and is not yet ready for testing.
  • It also creates a workflow for triage and testing follow-up in order to move the ticket closer to resolution.

#4 @hellofromTonya
3 years ago

Proposal:

In addition to needs-testing-info, I propose adding has-testing-info keyword.

Why?

needs-testing keyword by itself does not indicate the ticket's patch is ready for testing. Rather, it's a flag to know that the ticket will require testing when it's ready.

Adding needs-testing-info keyword flags more information is needed to know how to reproduce and do the testing as well as what the acceptable state/criteria are (ie expected behavior and acceptance criteria). This keyword is applied manually. The absence of this keyword does not indicate the ticket is in a testable state.

Adding has-testing-info is a positive indicator. The combination of needs-testing + has-testing-info creates a ready for testing workflow. Now the ticket can be scheduled in a testing scrub and/or a call for testers.

#5 @ironprogrammer
20 months ago

Adoption Update

Since their proposal during the 5.6 cycle, usage of the keywords needs-testing-info and has-testing-info has steadily gained traction, and their use is regularly encouraged during test triage.

The increased consistency of use can also be found in Trac tickets, as well as in test-related posts.

Further Improving Adoption

Building on previous comments in support of these keywords, by including them in the Workflow Keywords dropdown, contributors will be able to more easily access and apply these keywords.

The current Manual entry option is not intuitive, and many contributors may not realize these keywords exist and are regularly used. Additionally, copy/pasting or manually typing these keywords can be subject to typos that defeat the purpose of keyword consistency in Trac.

Keyword Descriptions

In addition to my support for making these keywords official, I would like to suggest these corresponding Trac Workflow Keywords notes that would accompany their addition.

needs-testing-info
Contributors have requested a more detailed testing procedure to reproduce the issue, or to validate a patch works as expected.

has-testing-info
This keyword indicates that steps have been provided to reproduce the issue or test a patch.

#6 @SergeyBiryukov
20 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 12154:

Trac: Add has-testing-info and needs-testing-info keywords.

Follow-up to [183], [1952], [3216], [7497], [8109], [8110], [8441], [8453], [9053], [10509], [11775], [11776], [11798].

Props davidbaumwald, hellofromTonya, ironprogrammer.
Fixes #5634.

#7 @SergeyBiryukov
20 months ago

In 12155:

Trac: Bump scripts version after [12154].

See #5634.

#8 @dd32
20 months ago

In 12156:

Trac: Fix JS syntax error after [12154].

See #5634.

Note: See TracTickets for help on using tickets.